When navigating to the Analysis & Review page on any case, the pop-up error 'Unable to Retrieve Node Info' appears.

Article: 100053357
Last Published: 2022-06-27
Ratings: 1 0
Product(s): eDiscovery Platform

Problem

When attempting to navigate to the Analysis & Review page from Case Home, the pop-up error 'Unable to Retrieve Node Info' appears and the end user is unable to enter any case review.
 

Error Message
 

On user interface:

"Empty or Invalid respose received from server"


 

<< Server Log >>

ERROR [handler.redirection.RedirectionHandler] (http-nio-80-exec-16-JE:[]) CaseName:[]  UserName:[TestUser] [71001] Error while getting redirection information: 
ERROR [resource.redirection.RedirectionResource] (http-nio-80-exec-16-JE:[]) CaseName:[]  UserName:[TestUser] [71001] [71001] Internal server error.
INFO  [ui.util.HttpSessionTracker] (http-nio-80-exec-11:[]) Session 1338454408 ( 7924ADEA0A1DC2A841C01ED199840876) about to be destroyed for TestUser
INFO  [ui.util.HttpSessionTracker] (http-nio-80-exec-18:[]) Session  created for user TestUser.
INFO  [util.redirection.RedirectionHelper] (http-nio-80-exec-20-JE:[]) CaseName:[]  UserName:TestUser] Redirecting user TE to eDP-App1.edp.lab
WARN  [STDERR] (http-nio-80-exec-20-JE:[]) java.io.IOException: DER length more than 4 bytes: 109

ERROR [reports.rest.SSLProtocolSocketFactory] (http-nio-80-exec-20-JE:[]) DER length more than 4 bytes: 109
java.io.IOException: DER length more than 4 bytes: 109

 

Cause

One or more, of the three SSL keystores is corrupt or not in the BCKFS format introduced in eDiscovery version 10.0.0

 

Solution

Locate and repair the corrupt / wrong format certificate keystore.

  1. Download the Keystore Explorer tool.
    Select 'Open an existing keystore' and navigate to each keystore.
  2. Verify the keystore will open with the expected password.
    Verify the KeyStore Type is BCFKS

Keystore locations:
    D:\CW\V10.0.x\scratch\temp\cert
    D:\CW\V10.0.x\Tomcat\conf\server.keystore
    C:\jdk-8u3##-windows-x64\jre\lib\security\cacerts

If the corrupt keystore is D:\CW\V10x\scratch\temp\cert:

  1. Stop eDP services
  2. Delete the CERT file
  3. Start eDP services
  4. Repeat the above steps to verify the CERT keystore is in BCFKS format.
     

 

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