WARN LitHold [#80085] Runtime exception: Exception in installing the server certificate required for HTTPS. : null
Problem
The customer is not running Legal Hold module or using eDiscovery for Legal Holds. However there are LitHold warning messages flooding the server log for the appliance.
Error Message
2021-09-14 11:09:21,715 WARN [litholds.server.SurveyRespMgrImpl] (Survey Response Monitor Thread:[]) Error Processing Record
com.teneo.esa.litholds.service.TeneoSSLHandshakeException: [#80085] Runtime exception: Exception in installing the server certificate required for HTTPS. : null
at com.teneo.esa.litholds.service.WSClientHelper.getClient(WSClientHelper.java:80) ~[testclasses/:?]
at com.teneo.esa.litholds.server.ParallelSurveyRespIterator.getLitHoldServiceClient(ParallelSurveyRespIterator.java:71) ~[testclasses/:?]
at com.teneo.esa.litholds.server.ParallelSurveyRespIterator.<init>(ParallelSurveyRespIterator.java:58) ~[testclasses/:?]
at com.teneo.esa.litholds.server.SurveyRespMgrImpl$ConfMonitorThread.processPendingResponses(SurveyRespMgrImpl.java:171) ~[testclasses/:?]
at com.teneo.esa.litholds.server.SurveyRespMgrImpl$ConfMonitorThread.run(SurveyRespMgrImpl.java:117) [testclasses/:?]
Caused by: java.lang.NullPointerException
Cause
Properties for the unlicensed Legal Hold module are set in the customer's environment, causing the log errors.
Solution
On the affected appliance. Check the System > Settings > General tab. Are the following fields populated?
- Confirmation server hostname/IP
- Admin server hostname/IP
- Note: If either the above fields have values, remove those values and click Save.
In System > Settings > Support Features > select Property Browser in the drop-down,
- In Pattern to match, enter the following properties separately and click Submit
- esa.icp.litholds.isConfirmationServer
- esa.icp.confirmation.webservices.useHttps
- Note: If either value is set to true, change the value to false
- Enter the property in Name of property to change
- Enter false in New Value (leave blank to remove)
- Check Confirm change. Are you sure?
- Click Submit
- Note: A services restart is required for any changes to take effect.