Problem
Catalog backups fail with Status 160 when the Disaster Recovery path is in CIFS format, thereby requiring a Login ID and Password
Example
Error Message
In the Activity Monitor, the parent job will fail with "Authentication failed (160)":Sep 20, 2021 4:36:37 PM - begin Parent Job
Sep 20, 2021 4:36:37 PM - begin Catalog Backup:Database Manager Query
Sep 20, 2021 4:37:37 PM - Error bpdbm (pid=7576) Unable to create disaster recovery package at \\COLOSSUS\drfile\Hot-Catalog_1632173840_FULL.drpkg: authentication failed (160)
Operation Status: 160
Sep 20, 2021 4:37:37 PM - end Catalog Backup:Database Manager Query; elapsed time 0:01:00
Sep 20, 2021 4:37:37 PM - begin Catalog Backup:Stop On Error
Operation Status: 0
Sep 20, 2021 4:37:37 PM - end Catalog Backup:Stop On Error; elapsed time 0:00:00
Operation Status: 160
Sep 20, 2021 4:37:37 PM - end Parent Job; elapsed time 0:01:00
Authentication failed (160)
Cause
The file ...\NetBackup\db\class\<PolicyName>\catdrinfo contains "PASSWORD (null)
" where the encrypted password should be stored. This is caused by an issue with the Java Console when saving the password.
ExamplePATH \\COLOSSUS\drfile
USER_NAME COLOSSUS\NBU_Service_Account
PASSWORD (null)
FLAGS 1
Solution
This issue is supposed to occur in NetBackup 8.3.0.1, 9.0, and 9.0.0.1.
This issue is resolved in NBU 9.1
Workaround:
Because this issue is due to a Java Console defect, NetBackup commands are not affected.
To work around this issue, the username and password can be successfully added to the existing catalog backup policy using the 'bpplcatdrinfo
' command.
<InstallPath>\NetBackup\bin\admincmd\bpplcatdrinfo <PolicyName> -set -u <UserName> -pwd <Password> -p <Path>
Example:bpplcatdrinfo Hot-Catalog -set -u COLOSSUS\NBU_Service_Account -pwd <mysecurepwd> -p \\COLOSSUS\drfile