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Problem
After an upgrade to OpsCenter v9.1 through 10.0.0.1 is completed successfully and all services are started, attempts to login to the Web page results in the page not loading and the error is "Connection refused."
Error Message
Connection refused when trying to load the Web page.
When trying to back up the database:
C:\PROGRA~1\Symantec\OPSCEN~1\server\config\security\.yekabcdefghij
1 File(s) copied
ERROR backing up the OpsCenter Database, Exiting...
When trying to change the database password:
C:\Program Files\Symantec\OpsCenter\server\bin>changeDbPassword.bat
OpsCenter Services should be restarted for database password change to be effective
Do you want to restart the services(y/n)y
Please enter the OpsCenter admin password:
JNI_AtInitEx: received j_flag value: 0JNI_AtInitEx: sending flags value: 0
[Thu Aug 12 10:07:22 EDT 2021 - SecurityManager] SecurityManager INFO: Setting AT Client logging...
[Thu Aug 12 10:07:22 EDT 2021 - SecurityManager] SecurityManager INFO: Setting AT Client logging, eatVerbose:1
JNI_AtInitEx: received j_flag value: 0JNI_AtInitEx: sending flags value: 0
[Thu Aug 12 10:07:23 EDT 2021 - OpsCenterATLogger] EAT_LOG:(Windows_NT/at_sock.c,167)select error on socket(2100): 10061
[Thu Aug 12 10:07:23 EDT 2021 - OpsCenterATLogger] EAT_LOG:(at_sockaddr.c,161)connect host <lgccapp8.laguardia.cc:1556> failed; err -1
The <INSTALL_PATH>\Symantec\OpsCenter\gui\webserver\logs\catalina.YYY.mm.dd.log showed:
keytool error: java.io.IOException: Keystore was tampered with, or password was incorrect
Cause
During the upgrade process, the keystore was not upgraded successfully.
Solution
To resolve the issue with the keystore:
1. Rename the existing jkskey file:
From: <INSTALL_PATH>\Symantec\OpsCenter\gui\config\jkskey
To: <INSTALL_PATH>\Symantec\OpsCenter\gui\config\jkskey_orig
2. Rename the existing keystore:
From: <INSTALL_PATH>\Symantec\OpsCenter\gui\Security\keystore
To: <INSTALL_PATH>\Symantec\OpsCenter\gui\Security\keystore_orig
3. Generate a new keystore and jkskey file by executing the createSSLStore.cmd command
<INSTALL_PATH>\Symantec\OpsCenter\gui\bin\goodies\creatSSLStore.cmd
4. Ensure the keystorePass= entry in the server.xml file matches what is in the newly created jkskey file
- Open the server.xml file for editing as an Administrator:
<INSTALL_PATH>\Symantec\OpsCenter\gui\webserver\conf\server.xml
- Search for 'keystorePass' without the quotes.
- Make sure that keystorePass= is set to what's in the jkskey file just created
<INSTALL_PATH>\Symantec\OpsCenter\gui\config\jkskey
5. Restart OpsCenter services:
<INSTALL_PATH>\Symantec\OpsCenter\server\bin\opsadmin stop
<INSTALL_PATH>\Symantec\OpsCenter\server\bin\opsadmin start
The Web page should now load with the login available.