Failure when changing Fibre Transport Settings from appliance web console on NetBackup 5350 Appliance

Article: 100049670
Last Published: 2021-05-17
Ratings: 0 0
Product(s): Appliances

Problem

When the Fibre Transport option is enabled and zoned with several HBA ports set to Initiator, changing the port configurations from the appliance web console to FTMS Target or MSDP Target may fail.

Error Message

"Error in updating SAN client flag configuration" "Error while disabling the Fibre Transport."

Cause

A timeout occurs when the process attempts to disable the target mode on an HBA port. If the HBA port state appears as "Unknown", the attempt may exceed the timeout limit, depending on the number of remote ports that are trying to attach to the target port.

Solution

When the errors described above appear, the process is still running in the background. To monitor the progress, log in to the appliance shell menu and run the following command:

Main_Menu> Manage > FibreChannel > FC Show

Within a few minutes, the port state configuration changes should complete and the status for the affected ports should change from "Unknown" to "Online".

 

Workaround

When the target mode is enabled for an HBA port, the port may not come 'Online' for some time based on the number of remote ports that are trying to attach to the target port. More time is required when a higher number of ports (10 or more) are trying to attach to the target port. Use the following guidelines to work around this issue:

  • Always change Fibre Transport Settings when the status of all HBA ports are either 'Online' or 'Linkdown'.

  • When updating Fibre Transport Settings from the appliance web console, it's recommended to first disable the zones of the appliance HBA ports, change the port configurations as needed, then re-enable the zones on the FC switcher.
  • Use the appliance shell menu to update the Fibre Transport settings to avoid the timeout when 10 or more remote ports are attaching to the target port.

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