問題
リモートサーバーのバックアップ中に、ランダムなバイトカウントでエラーメッセージ 「ターゲットシステムへの接続が切断しました」 が発生する。
エラーメッセージ
ジョブログには、次のエラーが表示されます:
最終エラー: 0xe000fe30 - 通信障害が発生しました。
Backup- \\ServerName.local\C:
V-79-57344-65072 - ターゲットシステムへの接続が切断しました。バックアップセットはキャンセルされました。
Verify- \\ServerName.local\C:
V-79-57344-34004 - 予期しないデータセットの終端を検出しました。
メディアサーバー側のデバッグログには、次のエラーが表示されます:
[5600] [ndmp\tpfmt] - Socket error mvrRet = 10054
[3248] [ndmp\tpfmt] - TF_GetNextTapeRequest( ) Error = E00084F9
[3248] [ndmp\tpfmt] - TF_GetNextTapeRequest( ): Recalled in Error State
[3248] [ndmp\tpfmt] - TF_GetNextTapeRequest( ): Recalled in Error State
[3248] [ndmp\tpfmt] - TF_CloseSet()
[3248] [ndmp\tpfmt] - Fatal error in channel.
UMI:- V-79-57344-65072
原因
Winsock エラー 10053 および 10054 は、オープンシステム相互接続モデル (OSI モデル) のネットワーク層以下のレイヤーで発生する TCP/IP エラーです。クライアント側とサーバー側の両方で、Backup Exec、Exchange、SharePointなどのアプリケーションは、ネットワーク層よりも上位のアプリケーション層で動作します。信頼性の高いネットワーク接続を確立および維持する責任は、Backup Exec よりも下位のレイヤーにあります。安定した TCP/IP 接続を維持できず、これらのエラー(10053 または 10054)を受信すると、Backup Exec はバックアップを続行できません。
このエラーが常に発生する状況では、クライアントマシンからメディアサーバーへの大きなファイルのコピーも失敗することがよくあります。これは、問題がオペレーティングシステム(OS)またはハードウェアレベルにあることを示しています。
解決策
1. 既存の問題が発生していることを確認するには、メディアサーバーのデバッグをオンにし、バックアップを再実行します。 バックアップが失敗したら、メディアサーバーのデバッグログに "Socket error mvrRet = 10054" が発生していることを確認します。このエラーはバックアップ中にネットワークエラーが発生していることを意味します。
2. ネットワークインターフェースカード (NIC) のドライバーとファームウェアが最新のアップデートレベルであることを確認します。
3. バックアップ対象サーバーの RSS、NetDMA、TCP Chimney (オフロード機能) をオフにします。(手順はこちらを参考してください)
4. バックアップするデータ量以上のデータをネットワーク経由でメディアサーバーにコピーできることを確認します。
5. Veritas Quick Assist (VQA) を使用して、ネットワーク診断を実施します。