Important Update: Cohesity Products Knowledge Base Articles


All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.

VMware restore fails with Status 2820 if the VM consists sparse disk

Article: 100049420
Last Published: 2021-01-27
Ratings: 0 0
Product(s): NetBackup

Problem

VMware restore fails with Status 2820 if the VM consists sparse disk. An error can also be seen when trying to clone a VM using the vCenter UI.

 

Error Message

Findings from the bpvmutil.log

<ns2:fileOperation>create</ns2:fileOperation><ns2:device xsi:type="ns2:VirtualDisk"><ns2:key>-3000</ns2:key><ns2:backing xsi:type="ns2:VirtualDiskSparseVer2BackingInfo"><ns2:fileName>[Datastore] <vm_name>/<vm_name>.vm
11:34:25.070 [185555.185555] <2> virtlogcallback: vmwareLogger: WaitForTaskComplete: reached Error!
11:34:25.070 [185555.185555] <2> virtlogcallback: vmwareLogger: WaitForTaskComplete: The device or operation specified at index '3' is not supported for the existing virtual machine platform. <249>
11:34:25.557 [185555.185555] <2> virtlogcallback: vmwareLogger: <?xml version="1.0" encoding="UTF-8"?> <SoapFault xsi:type="ns2:DeviceUnsupportedForVmPlatform"><ns2:property>VirtualDeviceSpec.device.backing</ns2:property><ns2:deviceIndex>3</ns2:deviceIndex></SoapFault>
11:34:25.557 [185555.185555] <2> virtlogcallback: vmwareLogger: WaitForTaskComplete: Completed SoapFault dump.
11:34:26.904 [185555.185555] <16> createVMwareVM: Create virtual machine failed for <vcenter_name> with 36

 

Cause

This issue can occur if the VM has a 'sparse' disk attached to it and it might have been converted from a different source.  This format is compatible with Hosted (desktop) products such as VMware Fusion, Player, Server, Workstation, etc. Virtual machine disks are spanned across several 2GB extents to eliminate potential cross-platform file system compatibility issues.
 

Solution

 Workaround:
 
 Please use the option to restore Virtual Disk instead of Virtual Machine in NetBackup.
 Choose to use a Disk provision (Thick/thin).


This will create a new Temporary VM with the restored disk attached.  After the restore is successful you can try to detach the disk and attach it to the Source VM or any alternate VM.

To permanently fix the issue please work with your VMware team to change the disk format to a supported disk format. This can also be accomplished using the below tool from VMware.

vmkfstools -d --diskformat [thin|zeroedthick|eagerzeroedthick]

For example:

# vmkfstools -i old.vmdk -d zeroedthick new.vmdk

For more information see:
https://kb.vmware.com/s/article/1028042

https://kb.vmware.com/s/article/1030098

Was this content helpful?