問題
Veritas Desktop and Laptop Option (DLO) エージェントが無効状態になり重複排除エンジンがオフラインのメッセージが表示されます。
重複排除エンジンが初期化に失敗しています。システム管理者に連絡してください。
エラーメッセージ
DLOClient.log ファイルに次のエラーが表示されます。
Failed to login to Dedupe server.Error Code: 23522
DLOClient.log と DDEngine_1.log に次のエラーが表示される場合があります。
Failed to login to Dedupe server.Error Code: 22020
原因
この問題は、クライアントが重複排除サーバまたはDLO 管理サーバの重複排除ストレージロケーション (DSL) にアクセスできない場合に発生します。
解決策
トラブルシューティングのヒント:
重複排除サーバがアクセス可能な状態にあるかどうかを確認するには、次の手順を実行します。
・重複排除サーバがアクティブ状態かどうかを確認します。ブラウザに次の URL を入力します。
https://DedupeServerHostName:8443
http://DedupeServerHostName:8080
・Mindtree StoreSmart Dedupe Service が重複排除サーバで実行されているかどうかを確認します。
・重複排除ユーザアカウントのパスワードが変更されたか期限切れになっていないかを確認します (重複排除ユーザアカウントは重複排除ストレージロケーション(DSL)を追加するときに使用したアカウントです。必要に応じてアカウントとパスワードを更新します。)
・ 重複排除サーバがメンテナンスモードになっているかどうかを確認します。
・重複排除ユーザアカウントを使用して問題のあるクライアントマシンにログインし、重複排除ユーザアカウントが重複排除ストレージロケーション(DSL)にアクセスできることを確認します。
上記の手順をすべて確認した後、DLO エージェントを終了して再起動し、問題が解決したかどうかを確認します。
・問題が解決しない場合は、デバッグ ログ (DLOClient.log およびDDEngine_1.log) を確認し、次のエラーを探します。
・DLOClient.log (C:\Users\UserName\AppData\Local\Veritas\DLO\.settings)
Failed to login to Dedupe server.Error Code: 23522
Failed to login to Dedupe server.Error Code: 22020
・DDEngine_1.log (C:\Users\UserName\AppData\Local\Veritas\DLO\.dlo\DedupeStore)
Error Code = 23522; Error Message = The UserHashStore DB is not found
この特定のエラー コードは、DLO コンソール上の 重複排除サーバ に使用されているアカウントが正しく構成されていないために発生します。
重複排除ユーザはドメインユーザーアカウントでかつDLO管理サーバーのローカルAdministratorである必要があります。このアカウントには、DLO ストレージフォルダに対するフル コントロールと、DLO ストレージ共有のフル コントロールを次のように設定する必要があります。
・ドメイン管理者アカウントではなく、ドメインユーザアカウントを作成します。
・パスワードが期限切れにならないようにアカウントを構成します。
・重複排除ストレージの場所があるサーバでローカル管理者として設定します。
・重複排除フォルダのフル コントロールと、そのフォルダの共有のフルコントロール権限を与えます。
・DLO 管理コンソールが配置されているサーバでローカル管理者として設定します。
・変更後に、管理サーバーとクライアントの両方ですべてのサービスを再起動します。
・必要に応じてクライアントのタスクマネージャーで DLOClientu.exe プロセスを停止します。