Event ID 41604 occurs stating indexing failed to fetch content due to timeout

Article: 100048809
Last Published: 2026-01-08
Ratings: 12 2
Product(s): Enterprise Vault

Problem

This event can occur when using Enterprise Vault (EV) SMTP archiving and there are many MIME message being archived.  

Error Message

Log Name: Veritas Enterprise Vault
Source: Enterprise Vault
Date: 10/27/2020 3:40:53 AM
Event ID: 41604
Task Category: Index Volumes Processor
Level: Warning
Computer: EVSERVER.EV.LOCAL
Description:
Indexing failed to fetch item content from StorageCrawler due to timeout. ISN: '154567', SavesetID: '202010263746404~202010262103010000~Z~D01BCAF5DDE96B524923F21B5C5EF681'.

If this error occurs frequently, increase the value of 'Maximum item wait time' on the Advanced tab of the Enterprise Vault Indexing server properties in the Administration Console.

V-437-41604

Cause

This issue seems to occur when there is an increased amount of MIME messages being archived.  

 

Solution

Add the following DWORD registry values under the registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\KVS\Enterprise Vault\Storage to every EV server, and then restart the EV Storage Service:

Registry value Value
CrawlerPreFetchThreadPoolSize 1
CrawlerMaxProcs 30 (Decimal)  Default: 10
CrawlerMaxClients 1

 

Warning: You must use these recommended values. Any other values will either be ineffective or cause problems with indexing backlogs.

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

References

JIRA : CFT-813

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