SMTP Archiving e-mails are moved to the SMTP Holding Failed folder when Enterprise Vault is in backup mode
Problem
SMTP Archiving e-mails are moved to the SMTP Holding Failed folder when Enterprise Vault is in backup mode
Error Message
Event ID: 41549 - Unable to archive the file 1597757640.1204.39369.eml. The file has been moved to .. \18\13\34\Failed. Reason: Unable to cast object of type 'Symantec.EnterpriseVault.SmtpCommonTarget' to type 'Symantec.EnterpriseVault.SmtpCommon.SmtpJrnlTarget'. Task:SMTP Archiving task
Cause
SMTP Archiving task based on the error encountered decides if the item needs to be moved to the failed items folder or not. The errors occurring while the Storage Service is busy or in backup mode are considered as temporary errors and such items will not be moved to failed items folder.
However, before SMTP Task can decide that, a Cast Exception occurs (non transient). This causes these specific items to be moved to failed items folder.
Solution
This issue has been addressed as part of Enterprise Vault 12.5.3 and Enterprise Vault 14.0.