Problem
During Cloud Catalyst storage configuration, we reach out to the cloud vendor to obtain information. In the event that communication fails, the configuration will fail with errors like "invalid command parameter(20)"
Error Message
Setting ESFS name and Local cache directory for <bucket_name>-invalid command parameter(20)
RDSM has encountered an issue with STS where the server was not found: getStorageServerConfig
tpcommand logs:10:08:33.237 [15315] <16> gcpsccbits05: AmzResiliency: AmzResiliency::getRetryType cURL error: 60, multi cURL error: 0, HTTP status: 0, XML response: None, RetryType: RETRY_NOT_APPLICABLE
10:08:33.237 [15315] <2> gcpsccbits05: AmzResiliency: AmzResiliency::getRetryType leave..
10:08:33.238 [15315] <16> gcpsccbits05: CurlHttpClient: CurlHttpClient::processCompletedEasyHandle : retry failed with STS error 2060019 ("error occurred on network socket").
10:08:33.238 [15315] <16> gcpsccbits05: libsts opensvh() 20/07/29 10:08:33: v11_open_server failed in plugin /usr/openv/lib/ost-plugins/libstspiamazon.so err 2060205
10:08:33.238 [15315] <16> gcpsccbits05: metering: Failed to open a new session, return: 2060205
10:08:33.238 [15315] <16> gcpsccbits05: libsts opensvh() 20/07/29 10:08:33: v11_open_server failed in plugin /usr/openv/lib/ost-plugins/libstspigateway.so err 2060205
10:08:33.238 [15315] <16> Valid_STS_Server: Failed to open server connection to type PureDisk_google_rawd server <bucket_name>: Error = 2060205 An error occurred in the cloud S3 subsystem
Cause
SSL certificate issue when communicating with 3rd party. In this case the curl 60 error is "unable to get local issuer certificate".
Solution
Using curl commands you can test communication with google apis:
Pre-NetBackup 8.2:
# curl -vvI --cacert /usr/openv/netbackup/db/cloud/cacert.pem https://storage.googleapis.com
NetBackup 8.2 and higher:
# curl -vvI --cacert /usr/openv/var/global/wmc/cloud/cacert.pem https://storage.googleapis.com
If curl returns and error, this must be addressed before NetBackup can proceed.
One known issue:
1. Verify the time on the local machine is correct.