Problem
Attempting a conversion of any Word document always fails. Additionally, other conversions may work just fine (Excel, Powerpoint, etc).
Error Message
In the Muhimbi Document Converter Diagnostics - WS Diagnose tab:7/14/2020 1:40:54 PM - Client opened
7/14/2020 1:40:54 PM - Service URL: http://localhost:41734/Muhimbi.DocumentConverter.WebService/
7/14/2020 1:43:05 PM - ConverterType: HTML - Valid: True - ExceptionType: Unknown
7/14/2020 1:43:05 PM - ConverterType: WordProcessing - Valid: False - ExceptionType: ConverterNotResponding
In the Muhimbi Document Converter Diagnostics - WS Convert tab:7/14/2020 1:46:35 PM - 8 - Client opened
7/14/2020 1:46:35 PM - 8 - Opening file: C:\Users\xxxxx\Documents\test document.docx
7/14/2020 1:46:35 PM - 8 - File length: 11362
7/14/2020 1:48:36 PM - 8 - FaultException occurred: ExceptionType: ConverterNotResponding
System.ServiceModel.FaultException`1[TestHarness.DocumentConverterService.WebServiceFaultException]: Muhimbi.DocumentConverter.WebService.Data.WebServiceInternalException: Exception of type 'Muhimbi.DocumentConverter.WebService.Data.WebServiceInternalException' was thrown. - Details: ""
at Muhimbi.DocumentConverter.WebService.WordProcessorConverterFullFidelity.Convert()
at Muhimbi.DocumentConverter.WebService.DocumentConverterService.ConvertByteArray(Byte[] sourceFile, OpenOptions openOptions, ConversionSettings conversionSettings, Boolean checkLicenseStatus) (Fault Detail is equal to TestHarness.DocumentConverterService.WebServiceFaultException).
Event Viewer Application log:
#1Log Name: Application
Source: Muhimbi.DocumentConverter.Service.exe
Date: 7/14/2020 1:48:36 PM
Event ID: 41734
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: server.com
Description:
Thread: 13
Level: ERROR
Source: Muhimbi.DocumentConverter.Service
Message: An error occurred while converting a file. - test document.docx. Muhimbi.DocumentConverter.WebService.Data.WebServiceInternalException: Exception of type 'Muhimbi.DocumentConverter.WebService.Data.WebServiceInternalException' was thrown. - Details: ""
at Muhimbi.DocumentConverter.WebService.WordProcessorConverterFullFidelity.Convert()
at Muhimbi.DocumentConverter.WebService.DocumentConverterService.ConvertByteArray(Byte[] sourceFile, OpenOptions openOptions, ConversionSettings conversionSettings, Boolean checkLicenseStatus)
#2Log Name: Application
Source: Muhimbi.DocumentConverter.Service.exe
Date: 7/14/2020 1:48:36 PM
Event ID: 41734
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: server.com
Description:
Thread: 8
Level: ERROR
Source: Muhimbi.DocumentConverter.Service
Message: Task is not responding, terminating - 6768 - WINWORD
Cause
This is caused by DCOM permissions.
Solution
Muhimbi prerequisites:
1. Verify the Muhimbi Document Converter Service (MDCS) account (ESADocImager by default) has local Administrator rights.
2. Log in as the MDCS service account and open Word. Ensure it is activated. Close it.
3. Ensure XPS Document Writer is the default printer. (Start > View Devices and Printers > right click Microsoft XPS Document Writer > ensure "Set as Default printer" is checked)
DCOM solution 1:
1. Open CMD
2. Run:
MMC -32
3. Navigate to File > Add/Remove Snap-in > Component Services > Add > OK
4. Expand Component Services (may take a moment) > Computers > My Computer > DCOM Config
5. Right click on Microsoft Word 97 - 2003 Document > Properties
6. Check that on the Location Tab "Run Application on this computer" is the only check box selected.
7. Check that on the Identity Tab the user account is set to the "Launching User".
8. Check that on the Security Tab "Launch and Activation permissions" and "Access Permissions" are set to "Use Default"
NOTE: If they are set to "Customize", please click edit and make a note of what each account is set to, so it can be reverted if needed.
9. Click OK and restart the ESAImagerHelper service.
10. Try to convert a Word document again.
DCOM solution 2:
NOTE: In the event that solution 1 did not resolve the issue, then attempt this solution.
1. Open CMD
2. Run:
MMC -32
3. Navigate to File > Add/Remove Snap-in > Component Services > Add > OK
4. Expand Component Services (may take a moment) > Computers > My Computer > DCOM Config
5. Right click on Microsoft Word 97 - 2003 Document > Properties
6. Select the Identity tab > click "This user" and enter the credentials of the MDCS service account.
7. Click OK
8. Restart ESAImageHelper service.
9. Try to convert a Word document again.