NetBackup Self Service ( NSS ) has problems connecting to the backup server using the REST API during the initial configuration

Article: 100047853
Last Published: 2020-07-10
Ratings: 1 1
Product(s): NetBackup & Alta Data Protection

Problem

NSS from 8.1.2 can use the REST API to connect to the NetBackup master server (also known as the backup server in NSS).  When adding a new backup server to the NSS system the ‘ Check Connectivity ‘ performs various checks and one is the REST API connection.

Before the REST API will connect there are several actions required on the NSS Web client and NetBackup master.

Error Message

REST Connection Status
Could not connect to the backup server REST API. The connection information is incorrect. Error
Message: An error occurred while sending the request.  The underlying connection was closed
Could not establish trust relationship for the SSL/TLS secure channel.

Cause

If the certificate, credentials, configurations in NSS, and a valid user for NSS on the master/backup server are not defined, then the REST API connection will fail and the ‘ Check Connectivity ‘ will not get a full pass.
 

Solution

Ensure the following steps have been followed:
 
1.  Under NSS ' Backup Servers ' section for the backup server which is failing to connect, enter the action / cog icon select ' View connectivity ' and where the ' REST Connection Status ' is showing the error, there is an option to  download the CA certificate, ' CA Certificate  Download '.
- Download the certificate to the NSS Web client. 
- Open the certificate downloaded
- In the Certificate window select ' Install Certificate '
- In the window ' Certificate Import Wizard ' select the option ' Local Machine ', then ' Next '.
- Continuing in the window ' Certificate Import Wizard ' select the option ' Place all certificates in the following store ', then ' Browse '
- In the ' Select Certificate Store ' window select the folder ' Trusted Root Certificate Authorities ', then ' OK '
- The window ' Certificate Import Wizard ' will now have the ' Certificate store: ' populated with ' Trusted Root Certificate Authorities ', then ' Next ' and then ' Finish '.
- Hopefully a message ' The import was successful. ' will appear, select ok on and ok on the Certificate window to complete/finish.
 
 
2.  Under NSS ' Backup Servers ' and for the backup server which is failing to connect, enter the action / cog icon select ' Edit Details ', scroll to the bottom and under the ' REST API Connection ' ensure the ' URL ' is correct with the master/backup server hostname and 1556 port  ( example:  https//netbackup-master-name:1556 ).
- Select the option ' Set Credentials '. 
- The ' Set REST API Credentials For Lab Master ' appear and here the NSS user and password and domain type must be set to provide access.  This is not the administrator, admin or root password and details, but a specific Self Service user configured on the master/backup server.
- Select ' Save ' after applying the details.
- Now (top right of the screen) select ' Show Advanced Settings '.  Check the ' REST API Connection ' details and if required select ' Ignore Certificate Errors '.
- Save any changes.
- Return to the ; Backup Servers ' main screen in Self Service and select the option ' Check Connectivity '.  Note, the cog icon will slightly move and change colour whilst updating, then when this has completed check the status (Actions -> View Connectivity).

 

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