Problem
“Media is in use” will contribute to delays for Duplication jobs when tape drives are involved, due to the tapes/media performing an unmount of the tape/media even though it's still required for several other images in the same batch (by design the media should stay mounted).
Error Message
Media is in use
Following message repeats over and over in activity monitor causing hours of delay:
14.04.2020 08:07:26 - awaiting resource <MEDIAID>. Waiting for resources.
Reason: Media is in use, Media server: N/A,
Robot Type(Number): NONE(0), Media ID: <MEDIAID>, Drive Name: N/A,
Volume Pool: N/A, Storage Unit: N/A, Drive Scan Host: N/A,
Disk Pool: N/A, Disk Volume: N/A
14.04.2020 08:10:19 - Waiting for scan drive stop <DRIVENAME>, Media server: <SERVERNAME>
Cause
Tapes drives will have the ' clean ' flag set (which can be seen via the Device Monitor or the output of the ' vmoprcmd ' command). When a tape drive is notified for cleaning the media server is still allowed to use the drive but will try and avoid using it unless it has to, which is why the unmount / dismount occurs (media timeout is set to 0 because the drive needs a clean). This will cause cause delays for the duplication process (tapes take time to dismount, mount and position the media again; note, the delays are less with a Virtual Tape Library (VTL) media), and the 'media is in use' message will appear in the job details as the next image in the duplication batch (separate bptm process) is trying to request the same media whilst the unmount / dismount is occurring for that same media for the previous duplication.
From nbemm (nbrb has similar messages):
05/14/20 08:07:25.331 [Debug] NB 51216 mds 143 PID:11212 TID:47 File ID:111 [No context] 1 [deallocate] REQUEST NEEDS TO BE RETRIED LATER - DRIVE NEEDS CLEANING
05/14/20 08:07:26.298 [Debug] NB 51216 mds 143 PID:11212 TID:39 File ID:111 [No context] 1 [deallocate] REQUEST NEEDS TO BE RETRIED LATER - DRIVE NEEDS CLEANING
Solution
Clean tapes before attempting further duplication jobs to avoid the media in use message and further delays.
There could be an additional issue with tape cleaning causing the error message, please investigate why tape cleaning is not being performed (tape cleaning can be a NetBackup, manual or library operation).
Once tapes are cleaned, Duplication jobs should complete as expected without delay or unmounting.