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nbcomponentupdate fails with: Veritas NetBackup Client does not support Java Runtime Environment(JRE) on Windows Operating System
Problem
Attempting to update JRE on a Windows client fails.
Error Message
Veritas NetBackup Client does not support Java Runtime Envrionment(JRE) on Windows Operating System
Cause
A base Windows client installation does not have any JRE to update.
Solution
If there is a scanner warning on a Windows client regarding the version of Java, check the path that is listed in the scan report. It may be necessary to update the JRE version for the operating system, or a third party application.
If the Java Administration console is installed on the Windows client and is the cause for the scanner error, then either:
- Update the JRE version for the Java console
- Uninstall the Java console
1. To update the Java console, change the product switch from NetBackup to RemoveJavaConsole in the nbcomponentupdate command, for example:
C:\"Program Files"\Veritas\NetBackup\bin\goodies\nbcomponentupdate.exe -product RemoteJavaConsole -component jre -path "C:\Program Files\Veritas\NetBackup\Temp\jre-8u431-windows-x64\jre1.8.0_431"
2. The console can be uninstalled through the Add/Remove Programs Windows servlet.