Problem
Backup/Duplication to Cloud Catalyst are failing after changing credentials to S3 provider
Error Message
Job Details:
Mar 25, 2020 7:30:49 PM - Critical bptm (pid=6914) Storage Server Error: Error while checking credentials for cloud storage
Mar 25, 2020 7:30:49 PM - Critical bptm (pid=6914) sts_open_server failed: error 2060205 An error occurred in the cloud S3 subsystem
Mar 25, 2020 7:30:49 PM - Critical bptm (pid=6914) failure to open sts for storage server my-S3Provider: plug-in reports error 2060205 An error occurred in the cloud S3 subsystem
Cause
Credentials were changed on the S3 provider, but NetBackup was not updated to use the new Credentials.
Solution
The command /usr/openv/volmgr/bin/tpconfig can be updated to update credentials.
# /usr/openv/volmgr/bin/tpconfig -update -storage_server <server name> -stype <server type> -sts_user_id <user ID> [-password <password>]
Next run the following command to verify the access key matches:
# /usr/openv/pdde/pdcr/bin/spauser -l
Restart the NetBackup services on the Cloud Catalyst server to re-read the configuration information:
# /usr/openv/netbackup/bin/goodies/netbackup stop
# /usr/openv/netbackup/bin/bp.start_all