NetBackup Legacy Client Service crashes every 15 minutes after upgrading VMware Tools to 11.x

Article: 100047181
Last Published: 2020-06-29
Ratings: 5 0
Product(s): NetBackup & Alta Data Protection

Problem

NetBackup Legacy Client Service crashes every 15 minutes after upgrading VMware Tools to 11.x when NetBackup is installed within the virtual machine.

Error Message

Application event log confirms error with Event 1000 (Application Error)

Faulting application name: bpinetd.exe, version: 8.102.18.827, time stamp: 0x5b8489ec
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005

Cause

A case was opened with VMware to determine what changed. They determined that the issue is caused by the new appinfo plugin feature in VMware Tools 11 querying the NetBackup services.

According to VMWare documentation appinfo is used for:

  • Collecting the information about running applications inside the guest and publishes the information to a guest variable.

3rd Party Reference:

Please note that this article is not owned or maintained by Veritas and, as such, Veritas is not responsible for the content portrayed on such sites, including any revisions to or deletions of content or third-party software on which this article relies. User is responsible for conducting all necessary due diligence prior to following the instructions described in this article.

Solution

This issue is resolved in VMware Tools 11.0.6:

3rd Party Reference:

Please note that this article is not owned or maintained by Veritas and, as such, Veritas is not responsible for the content portrayed on such sites, including any revisions to or deletions of content or third-party software on which this article relies. User is responsible for conducting all necessary due diligence prior to following the instructions described in this article.

Workaround

  1. You can disable appinfo:
    • Open a Command Prompt and change directories to: C:\Program Files\VMware\VMware Tools
    • Run command: vmwaretoolboxcmd.exe config set appinfo disabled true
  2. Veritas team has created a hotfix for bpinetd process to work around the VMware issue. Contact Veritas Support and request the following:
    • For NetBackup 8.1.2 - ET3992511
    • For NetBackup 8.2 - ET3996591

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