VMware Tools 10.1 stop responding during quiescing if Veritas VSS Provider is installed

Article: 100034202
Last Published: 2017-06-24
Ratings: 1 0
Product(s): NetBackup & Alta Data Protection

Problem

If Veritas VSS provider is installed on a virtual machine, VMware Tools 10.1 may stop responding during the quiescing operation that is performed when making a snapshot. This causes the snapshot job to fail.

Error Message

Virtual machine quiescing fails, causing the snapshot job to fail with error status code 156.

The following message can be seen in snapshot Job Details:

28.6.2017 14:58:04 - Critical bpbrm (pid=10120) from client testvm: FTL - vSphere_freeze: Snapshot task for virtual machine testvm (/vmmor/vm-867) failed, 10 retries remaining, error type: 268, error message: An error occurred while saving the snapshot: Failed to quiesce the virtual machine

Cause

This is caused by a known issue in VMware Tools 10.1. See the VMware (now Broadcom) KB article below for more details.

Please note that this article is not owned or maintained by Veritas and, as such, Veritas is not responsible for the content portrayed on such sites, including any revisions to or deletions of content or third-party software on which this article relies. User is responsible for conducting all necessary due diligence prior to following the instructions described in this article.

Solution

As per the vendor KB article 2149640 above, this issue is resolved in VMware tools version 10.1.10, available at VMware Downloads.

Workaround

The following workaround has been successfully tested with Veritas VSS provider:

  1. On the virtual machine, create a file C:\ProgramData\VMware\VMware Tools\Tools.conf and add these two lines:

[vmbackup]
enableVSS=false

  1. Using the Task Manager, terminate the vmtoolsd.exe process as it might have stopped responding during an earlier snapshot attempt.
  2. Using Services manager (services.msc), Start the VMware Tools service.

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