V-225-136: The patch failed to install. Return code: 1603 or ERROR: Installation failed with error 1603"

Article: 100046794
Last Published: 2022-12-12
Ratings: 2 6
Product(s): Backup Exec

Problem

Upgrade or Patching Backup Exec rolls back with Virtfile driver related error. Install log shows "V-225-136: The patch failed to install. Return code: 1603" or "ERROR: Installation failed with error 1603"

Some problems that may occur due to the rollback of Virtfile are --

1. The lockdown feature cannot be disabled or enabled.

2. Virtfile driver problems on Backup Exec Server or Remote server can cause GRT errors/exceptions. 
If GRT backup is targeted to Disk and exception or error is seen in the Job Log, then Virtfile problem should be checked on the Backup Exec server. If GRT backup is targeted to Tape and exception or error is seen in the Job Log, then Virtfile problem should be checked on Application Server which may be the Backup Exec server in certain cases.

V-79-57344-38721 - Failed to mount one or more virtual disk images

V-79-57344-844 - Cannot complete the operation because the Virtual File Filter (VFF) driver cannot be found. Ensure that the Agent for Microsoft Active Directory is installed and that the VFF driver is enabled and then retry. Alternatively, disable Granular Recovery Technology (GRT) and then retry

V-79-57344-65193 - The backup selection '\\ExchangeServer\Microsoft Information Store\Database'
was not successfully processed for Granular Recovery Technology (GRT). The Database Recovery
failed with Error '*Null*'. You will not be able to restore individual items for this backup
selection.

V-79-57344-4611 - An error occurred creating or accessing the directory \\.pdvfs\PFUSAM228WBAK02\2\BEData\STHVMDK specified for this operation. Ensure that the directory is accessible and can be written to.


3. The BE Storage may be offline and unable to read or write to the storage. The Tape storage will not display this Issue. 
 

Error Message

 

Backup Exec Install Log: 

C:\ProgramData\Veritas\Backup Exec\LOGS\BKUPINST20.html or BKUPINST21.html or BKUPINST22.html.

 

DIFXAPP: ERROR: Could not add driver store reference to the service.
DIFXAPP: ERROR: The driver installation failed. Attempting to undo system changes ... (Error code 0x643: Fatal error during installation.)
DIFXAPP: ERROR: encountered while installing driver package 'C:\Program Files\Veritas\Backup Exec\VirtFile\VirtFile.inf'
DIFXAPP: ERROR: InstallDriverPackages failed with error 0x643

ERROR: Installation failed with error 1603

Patch failure : V-225-136: The patch failed to install. Return code: 1603

 

Backup Exec Feature Pack Verbose Install Log (FP-6.cab/txt, FP-5.cab/txt, FP-4.cab/txt)

C:\ProgramData\Veritas\Backup Exec\LOGS\

DIFXAPP: INFO:   RETURN: DriverPackageInstallW  (0x65B)
DIFXAPP: ERROR: encountered while installing driver package 'C:\Program Files\Veritas\Backup Exec\VirtFile\VirtFile.inf'
DIFXAPP: ERROR: InstallDriverPackages failed with error 0x65B
DIFXAPP: RETURN: InstallDriverPackages() 1627 (0x65B)
CustomAction MsiInstallDrivers returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended  InstallExecute. Return value 3
.

 

OR


DIFXAPP: INFO:   RETURN: DriverPackageInstallW  (0x643)
DIFXAPP: ERROR: encountered while installing driver package 'X:\Program Files\Veritas\Backup Exec\VirtFile\VirtFile.inf'
DIFXAPP: ERROR: InstallDriverPackages failed with error 0x643
DIFXAPP: RETURN: InstallDriverPackages() 1603 (0x643)
Action ended  InstallExecute. Return value 3.

 

Cause
 

VirtFile driver update error.

 

Solution
 

Please contact Veritas Technical Support for further assistance with this Issue.

This issue is currently under investigation by Veritas Technologies LLC. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.
 
Note: Customers experiencing this issue are encouraged to contact Veritas Technical Support as data is still being collected to assist in resolving this issue.
 

References

Etrack : 4002305 Etrack : 3990764

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