NetBackup Web Management Console service does not start due to stale host cache entries

Article: 100046228
Last Published: 2020-03-18
Ratings: 0 1
Product(s): NetBackup & Alta Data Protection

Problem

NetBackup Web Management Console (NBWMC) service does not start due to stale host cache entries.

Error Message

N/A

Cause

The NetBackup Web Management Console (NBWMC) service fails to start on the Primary Server because the NetBackup Host Cache contains stale entries.

Solution

When this issue occurs, it is also observed that Catalina logs are not being generated.

Follow these steps to resolve the issue:

  1. Execute the following command to trace the NBWMC service startup process:
    • strace -fto /tmp/trace.out /usr/openv/netbackup/bin/nbwmc start
  2. In the trace output file (/tmp/trace.out), look for references to the bpclntcmd log located at:
    • /usr/openv/netbackup/logs/bpclntcmd
    • Example:
      86681 12:36:17 open("/usr/openv/var/global/nbcl.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
      86681 12:36:17 access("/usr/openv/netbackup/logs/bpclntcmd", F_OK) = 0
  3. Open the bpclntcmd log and search for the following entry:
    • Example:
      bpclntcmd_main: <primary_name> is not a local host: 48
    • If the above entry is found, delete the Host Cache directory to remove stale entries:
      • rm -rf /usr/openv/var/host_cache
  4. Attempt to start the NBWMC service again:
    • /usr/openv/netbackup/bin/nbwmc start
  5. Check the bpclntcmd log to confirm that the primary server is now recognized as a local host:
    • Example:
      bpclntcmd_main: <primary_name> is a local host

The Web Management Console service should now start successfully.

 

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