Problem
DMP (Dynamic Multipathing) Native support fails to get enabled after reboot on Infoscale 7.4 & 7.4.1 Over AIX Platform.
Error Message
# vxdmpadm native enable vgname=rootvgPlease reboot the system to enable DMP support for LVM bootability
** After Reboot of the system
# vxdmpadm native list VxVM vxdmpadm ERROR V-5-1-15206 DMP support for LVM bootability is disabled.
Cause
VxVM (Veritas Volume Manager) has a binary i.e vxdmpboot which runs at boot time to enable DMP Native Support for Root FileSystem.
The binary executes at a very early stage in the boot phase on the AIX platform and performs some licensing checks during execution. Earlier, the licensing specific library used to be a static library, but now it has been changed to Dynamic library.
At the boot time when the vxdmpboot binary is executed, most of the file systems are not mounted. The directory containing the Dynamic library is also not mounted and hence the library will not be available at boot time when the vxdmpboot binary is executed causing the failure in the licensing checks and failure of vxdmpboot execution. This failure prevents native support from getting enabled at boot time for Root Filesystem.
Solution
Licensing checks as part of vxdmpboot binary have been disabled to enable DMP native support successfully for root filesystem.
A supported hotfix has been made available for this issue. Please contact Veritas Technical Support to obtain this fix. This hotfix has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix.
Veritas Technologies LLC currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please note that Veritas Technologies LLC reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests. Veritas’ plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.