Progress log file incomplete during very large VMware agentless restore.

Article: 100045795
Last Published: 2019-06-24
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

When restoring one million or more files during an agentless restore to a Linux guest VM the progress log file may not be downloaded completely for viewing.

Additionally, the actual and estimated data transferred may diverge if there are a large number of small files less than 4KB in size.

Finally, VMDKs with staging data may remain attached on the guest VM.

Cause

The situation occurs when one million or more files are restored using VMware agentless restore.  The progress log, which is used by the UI is not downloaded completely and leads to the inconsistencies observed.

The estimaged kilobytes of data may not match what is listed in the transferred data in kilobytes field.

The number of files restored may not match the estimate number of files to be restored.

Solution

No data loss occurs, and no more or less data is restored than what was selected for restore.

In some cases, if the bpVMutil binary crashes VMDKs with staging data may be left connected to the Linux guest VM.  If this situation occurs, edit the guest VM configuration and remove the disks with the NB_<GUID> naming scheme, e.g., NB_xxxxxxxx_xxxx_xxxx_xxxx_xxxxxxxxxxxx.

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