Problem
Even when the Enterprise Vault Directory Database Transaction Log is not backed up for a considerable duration, the Enterprise Vault Monitoring module does not raise a warning event.
Due to this problem, the Administrator continues to remain under false assumption that the Enterprise Vault Directory Database (along with the Transaction log) is getting regularly backed up.
This problem occurs not only for Enterprise Vault Directory Database, but also for other Enterprise Vault databases.( Vault Store Database, Fingerprint Database, etc. )
Example:
This problem indicates that the following events is not reported in the Veritas Enterprise Vault at Applications and Services Logs.
If this function works correctly, when the Transaction Log is not backed up for a considerable duration, the following event is output to the event log.
---------------------------------------------------------------------------------------------------------------------
Log Name: Veritas Enterprise Vault
Source: Enterprise Vault
Date: 2/4/2019 9:00:03 AM
Event ID: 41015
Task Category: Monitoring
Level: Warning
Keywords: Classic
User: N/A
Computer: EV-EXCH.EXAMPLE.COM
Description:
The SQL database transaction log for the Enterprise Vault Directory database has not been backed up for 1 days.
The information in this database is at risk until the database has been backed up.
Review your SQL database backup procedures and make any changes needed to ensure that backups happen in a timely fashion.
---------------------------------------------------------------------------------------------------------------------
Cause
Backing up the database of Microsoft SQL server has a backup of the Transaction Log in addition to the database backup.
A Transaction Log backup contains all log records that have not been included in the last Transaction Log backup.
If the Transaction Log is never backed up or if its backup date is older than the base Database backup date, then Enterprise Vault faultily considers the Database backup date as the elapsed time since last backup for the Transaction log.
Solution
Temporary Solutions:
There are two temporary workarounds.
Method 1:
The correct date of the last backup can be confirmed from Last Database Log Backup in the database properties by connecting using SQL Server Management Studio.
Method 2:
Enterprise Vault includes a management pack for System Center Operations Manager (SCOM).
The pack defines rules that enable SCOM to monitor Enterprise Vault components and you can also monitor databases and logs backup correctly by using SCOM.
For using SCOM details, please refer to another Knowledge Base article 100015240 .
Monitoring Enterprise Vault
https://www.veritas.com/docs/100015240
Permanent Solution:
This issue has been addressed in EV 12.4.1.