Windows System State backups are partially successful due to an incorrect path for vsock.sys

Article: 100044722
Last Published: 2019-02-07
Ratings: 2 1
Product(s): NetBackup

Problem

Backups of System State during a MS-Windows incremental and/or full backups may result in an exit status 1, partially successful due to an incorrect path being registered with VSS for the vsock.sys file, as seen in bpbkar logs on the client.

Error Message

Job Details Snippet:

Jan 10, 2019 12:00:35 AM - begin writing
Jan 10, 2019 12:01:42 AM - Warning bpbrm (pid=99757) from client nbclient01: WRN - can't open object: System State:\System Files\System Files (WIN32 3758134305: Unknown error)
Jan 10, 2019 12:01:42 AM - Error bpbrm (pid=99757) from client nbclient01: ERR - Error encountered while attempting to get additional files for System State:\
Jan 10, 2019 12:01:48 AM - Info bptm (pid=99910) waited for full buffer 455 times, delayed 12977 times
Jan 10, 2019 12:02:07 AM - Info bptm (pid=99910) EXITING with status 0 <----------
Jan 10, 2019 12:02:07 AM - Info nbmedia02(pid=99910) StorageServer=PureDisk:nbmedia02; Report=PDDO Stats for (nbmedia02): scanned: 1314546 KB, CR sent: 45912 KB, CR sent over FC: 0 KB, dedup: 96.5%, cache disabled
Jan 10, 2019 12:02:07 AM - Info bpbrm (pid=99757) validating image for client nbclient01
Jan 10, 2019 12:02:08 AM - Info bpbkar (pid=680) done. status: 1: the requested operation was partially successful
Jan 10, 2019 12:05:01 AM - end writing; write time: 0:04:26
The requested operation was partially successful  (1)

 

bpbkar Log Snippet:

22:03:32.627 [680.5452] <2> ov_log::V_GlobalLog: INF - Status 0x00000003 returned calling FindFirstFile for \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy71\windows\systemroot\system32\drivers\vsock.sys in brUtil::GenerateFileList
22:03:32.627 [680.5452] <2> ov_log::V_GlobalLog: INF - Status 0x00000003 for file c:\windows\\systemroot\system32\drivers\vsock.sys in brUtil::GenerateFileList
22:03:52.330 [680.5452] <2> ov_log::V_GlobalLog: INF - Informational: Component:System Files no files are present to protect.
22:03:52.330 [680.5452] <2> ov_log::V_GlobalLog: INF - brUtil::SetBackupMethod(): Backup method set to BRU_BACKUP_METHOD_NORMAL(0) [Time=0]
22:03:52.330 [680.5452] <2> ov_log::V_GlobalLog: INF - Component Set System Files has 1 files missing on the snapshot
22:03:52.330 [680.5452] <2> ov_log::V_GlobalLog: INF -   AD:Status E_SNAPSHOT_ALL_COMPONENT_FILES_MISSING_ON_SNAPSHOT (0xE0009421) calling FS_OpenObj in SystemState::OpenObj:128
22:03:52.330 [680.5452] <2> ov_log::V_GlobalLogEx: ERR - beds_ss_access::V_OpenForRead(): FS_OpenObj() Failed! (0xE0009421:No component files present on the snapshot. )
22:03:52.330 [680.5452] <4> tar_base::V_vTarMsgW: INF - tar message received from dos_backup::tfs_readopen
22:03:52.330 [680.5452] <2> tar_base::V_vTarMsgW: WRN - can't open object: System State:\System Files\System Files (WIN32 3758134305: Unknown error)
22:03:52.330 [680.5452] <2> dtcp_write: TCP - success: send socket (696), 99 of 99 bytes
22:03:52.330 [680.5452] <2> ov_log::V_GlobalLog: INF -  v_beds::V_FindNext() EXIT Name: bRC:false LastError:0xFFFFFE07:0xa000fe07 (2684419591)
22:03:52.330 [680.5452] <4> tar_base::V_vTarMsgW: INF - tar message received from dos_backup::tfs_scan_up()
22:03:52.330 [680.5452] <2> tar_base::V_vTarMsgW: ERR - Error encountered while attempting to get additional files for System State:\

Cause

This VMware related file (vsock.sys) appears to have a path issue, as it should be referenced in this location:

c:\windows\system32\drivers\vsock.sys

The VMware Tools version may be confirmed in the client's Windows OS Application Event logs:

Thu Dec 27 2018 14:39:02    MsiInstaller    I1035  Windows Installer reconfigured the product. Product Name: VMware Tools. Product Version: 10.1.15.6627299. Product Language: 1033. Manufacturer: VMware, Inc.. Reconfiguration success or error status: 0.

VMware's forums include information to indicate a known issue with VMware Tools 10.1.x, per the 3rd party reference below:

 

3rd Party Reference (VMware):

Unable to backup Windows AD Server with VMware Tools installed

Note: While this external article specifies a Windows AD Server, the role does not appear to be of importance, only the VMware Tools version. 

Note: This link is an external reference that was valid at the time of this article's publication. 

Solution

Recommendation:

  • As this appears to be related to VMware Tools 10.1.x, please consult with VMware Support on this issue.

Suggestions:

  • As per VMware suggestion, upgrade the VMware Tools on the client to version 10.2.0 or higher.
  • For alternative options listed in the VMware forum post, again please consult with VMware Support.

After changes, if this was the only issue, then client/server should be able to backup successfully without any error messages.

If an exit status 1 issue persists, it's likely a different issue, please see Related Articles section for potential solution(s).

 

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