Enterprise Vault Search (EVS) is not returning results for users with large folder structures.

Article: 100044500
Last Published: 2025-07-14
Ratings: 1 1
Product(s): Enterprise Vault

Problem

When users have very large folder structures search may timeout.  

Error Message

Event ID 41315 may be seen in the Enterprise Vault Event Viewer log on the Enterprise Vault (EV) server. 

Event ID: 41315
Task Category: Index Query Server
Level: Warning
Description:
A search failed with error "The indexing engine is unable to perform the search due to lack of resources.".

V-437-41315

Cause

This issue is caused by having a large number of folders within the users archive.  The following can be seen in a Dtrace of the w3wp process on the EV server.  

(w3wp)    <37442>    EV-L    {EVS} ReturnAllSubfoldersFromDirectory() Archive folders count: [1398] || User: EV\User1

For more information on Dtrace please refer to the following article: 100038975

Solution

To resolve the issue, increase the Search Max Folders For Specific Folder Optimization setting. 

1. Open the Vault Admin Console as the Vault Service Account 

2. Right-click on the Site name and select Properties 

3. Click on the Advanced tab and select List settings from:  Indexing

4. Scroll down and click on Search Max Folders For Specific Folder Optimization, then Modify

5. Enter a number larger than the number returned in the Dtrace to accommodate the number of folders and click OK

6. Restart the Enterprise Vault Indexing Service

Once the value is increased, the search should return normally. 

 

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