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Problem
While performing the device configuration wizard, when customer selects the media server, and clicks next, it takes a while and returns, "globalDB hostname has not been set".

Error Message
globalDB hostname has been not been set. The system cannot find the file specified ( Status 4)
If you click on Host Properties of Media server it gives the below error :
"Configuration settings of the following hosts could not be obtained :
Hostname of the server
Failed to initialize EMM connects. Verify that network access to the EMM server is available and that the services nbemm and pbx_exchange are running on the EMM server.
(195)"

Cause
Issue is usually caused due to incorrect entries in bp.conf.
Solution
- Run nbemmcmd -listhosts on media server and see if it hangs, in case this command hangs then fix this issue.
Locations :
Unix: /usr/openv/netbackup/bin/admincmd/
Windows: InstallPath\Veritas\Netbackup\bin\admincmd\
- check "bp.conf" file and check the entry for media server and the master server name on both media server and master server.
Locations :
Unix: cat /usr/openv/netbackup/bp.conf
Windows: HKEY_LOCAL_MACHINE\Software\VERITAS\NetBackup\CurrentVersion\Config
Example the EMM Server name and the Server name has been added incorrectly.
SERVER = abc1
EMM SERVER = abc01
- Check if media server is newly added , if yes check licenses on media server , delete and add them again.
Refer article to View and List License information : https://www.veritas.com/support/en_US/article.000028825
- Verify the globDB
- Verify the globDB (Global Device Database) hostname by running the following command:
Unix : /usr/openv/volmgr/bin/vmglob -get_gdbhost
Windows: InstallPath\Veritas\Volmgr\bin\vmglob -get_gdbhost
- If the above command returns "globalDB hostname has not been set", then issue the following command:
/usr/openv/volmgr/bin/vmglob -set_gdbhost <volume database host>
The volume database host is usually the Master Server. At this point, it should be possible to continue configuring the devices. , if not correct this entry.
- Check name resolution . Check for REQUIRED_INTERFACE if set.
- Check hosts file entries on both Master and Media Server.
- Check if vmd service is running on media server , if not try to start vmd start check the OS logs and the daemon log.
To run vmd in debug mode do the following:
- Before you start vmd, create the following directory:
Unix : /usr/openv/volmgr/debug/daemon
Windows : InstallPath\Veritas\Volmgr\debug\daemon
- If vmd is running, stop, and restart it after creating the directory.
Start vmd in verbose mode as follows or put a VERBOSE entry in vm.conf.
Unix:/usr/openv/volmgr/bin/vmd -v
Windows : InstallPath\Veritas\Volmgr\bin\vmd -v
Check the log message in /usr/openv/volmgr/debug/daemon
- If VMD service started successfully , run device configuration again.
- If VMD service is going down make entry for vmd service in /etc/services , restart netbackup service again and run device configuration wizard.