Problem
Installation or upgrade of Backup Exec fails with error code 1603
Error Message
ERROR: Installation failed with error 1603. GetLastError = :0
BKUPINSTXX.HTM shows below..
: BEOps::BE_SetInstallProps
: BEOps::BE_SetInstallProps - Setting IS_OEM_VERITAS=1
: BEOps::BE_SetInstallProps - Unable to read SuppressDocuments from OEMInstallResources.xml. This optional setting may not exist. By default, SUPPRESS_DOCUMENTS=0
: BEOps::BE_SetInstallProps - Unable to read SuppressEULA from OEMInstallResources.xml. This optional setting may not exist. By default, SUPPRESS_EULA=0
: BEOps::BE_SetInstallProps - Unable to read SuppressHelpFiles from OEMInstallResources.xml. This optional setting may not exist. By default, SUPPRESS_HELP_FILES=0
: Failed to obtain all licensing values for SLF: .
: Failed to obtain all licensing values for SLF: .
: Failed to obtain all licensing values for SLF: .
: Failed to obtain all licensing values for SLF: .
: CustomAction PrepInstall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Cause
Unable to read the license files (SLF files) added in C:\ProgramData\Veritas Shared\Licenses\Backup Exec\Version folder.
Solution
Move all the SLF files from C:\ProgramData\Veritas Shared\Licenses\Backup Exec\Version of Backup Exec server to a TEMP location.
Complete the Backup Exec installation in Trial mode and add the licenses later through 'Installation and Licensing -- Install Features and Licenses on this Backup Exec Server' wizard.