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Problem
After upgrading NetBackup Appilance software release version 3.1.x, the Universal Share feature does not work properly.
Error Message
N/A
Cause
During upgrade, the content in the file '/msdp/data/dp1/pdvol/etc/pdregistry.cfg' is cleared between post-upgrade self-test and the last reboot of the appliance.
Solution
Verify the /msdp/data/dp1/pdvol/etc/pdregistry.cfg file by performing the following:
- Log on to the NetBackup Appliance Shell Menu as admin.
- Navigate to Support > Maintenance, then elevate to root.
- Verify the contents of the pdregistry.cfg file:
[Symantec/PureDisk/Install]
path=/usr/openv/pdde
[Symantec/PureDisk/Agent]
configfilepath=/msdp/data/dp1/pdvol/etc/puredisk/agent.cfg
path=/usr/openv/pdde/pdag
[Symantec/PureDisk/PDDE]
[Symantec/PureDisk/ContentRouter]
configfilepath=/msdp/data/dp1/pdvol/etc/puredisk/contentrouter.cfg
path=/usr/openv/pdde/pdcr
[Symantec/PureDisk/StoragePoolAuthority]
configfilepath=/msdp/data/dp1/pdvol/etc/puredisk/spa.cfg
path=/usr/openv/pdde/pdspa
[Symantec/PureDisk/VPFS]
configfilepath=/msdp/data/dp1/pdvol/etc/puredisk/vpfsd_config.json
path=/usr/openv/pdde/vpfs
- If the contents does not match edit the pdregistry.cfg with the above values, these values are only valid for MSDP, not valid for Cloud Catalyst.
- Log on to NetBackup Appliance Shell Menu
- Restart NetBackup processes using the following commands:
- Support > Processes > NetBackup Stop
Support > Processes > NetBackup Start
- Configure Universal Shares using the following command:
Support > RecoverStorage UniversalShares
- Wait for 10 minutes and reboot the appliance.