Problem
Advanced Search controls become unusable under certain circumstances
Error Message
This is what the interface looks like with the controls disabled. Note the grey color of the Save and Reset hyperlinks. Nothing happens when they or the button next to them are clicked.
Cause
The issue occurs on Enterprise Vault (EV) 12.3 when users are switching between the Simple and Advanced Search interfaces. When certain conditions are met, then the next time the user loads the EV Search (EVS) page within Outlook, the Save, Reset, and magnifying glass buttons will not be functional. They will do nothing when clicked, and the two text ones show in grey instead of blue.
This is caused by a problem with certain elements being improperly de-initialized in the page's Javascript.
Solution
This issue has been addressed in EV 12.4.1 available from Downloads.
The following workarounds have been found to work in some situations.
Workaround one:
Select any other archive folder than what is currently selected. After the resultant search, the controls will begin working again, and the original folder can be re-selected.
Workaround two:
Type an Advanced Search query in the criteria field(s) and hit Enter on the keyboard. The search will be submitted the same as if the magnifying glass button had been clicked, though the disabled interface elements will remain disabled.
Workaround three:
Change the EVS back to Simple, then close out of EVS and load it again. The page will load with the Simple Search interface, and all the buttons will work normally upon changing to Advanced. The issue only exists when the session loads straight into the Advanced Search interface.
Workaround four:
Use EVS in any supported standalone browser. The issue only exists when EVS is running inside Outlook.