Resolving upgrade failures on NetBackup appliances when WAN Optimization is disabled

Article: 100042878
Last Published: 2018-04-23
Ratings: 0 0
Product(s): Appliances

Problem

Appliance software upgrades from version 3.1 to version 3.1.1 fail and roll back to the previous version.

Error Message

Near the end of the upgrade, the post-upgrade self-test shows a Failed result, which automatically initiates a rollback. The vuf log file contains the following details:

++ cat /tmp/wanopt-config-tmp
+ infs='accif=""'
+ rm /tmp/wanopt-config-tmp
++ /usr/local/bin/platform model
++ /bin/grep 5100
+ is_model_5100=
+ logger is_model_5100=
+ '[' -n '' ']'
+ rm /etc/init.d/wanopt_network_sync
+ rm -rf /opt/veritas/appliance/wanopt
+ sed -e 's/^accif.$/accif="accif="""/' /opt/IMAppliance/appex/etc/config

....


LotServer is stopped!
+ '[' 1 = 0 ']'
+ '[' 1 = 1 ']'
+ /sbin/service lotServer start
Veritas License 176575C302C010D4
(license 176575C302C010D4)
Veritas License 176575C302C010D4
(license 176575C302C010D4)
Failed to write configuration: wanIf(accif=)

Cause

The upgrade script did not handle the Wan Optimization configuration correctly.

Solution

Contact Veritas Technical Support for assistance to resolve the issue and provide this article number to the representative. The next upgrade attempt to version 3.1.1 should succeed.

Caution: To avoid a potential kernel panic, do not enable Wan Optimization before the next upgrade attempt.

Was this content helpful?