Java Administration Console reporting "Could not connect to NBSL" followed by "Could not get Class_att_defs information" message

Article: 100042035
Last Published: 2020-02-27
Ratings: 0 3
Product(s): NetBackup & Alta Data Protection

Problem

When launching the Java Administration Console current version, or back-level Administration Consoles (base versions) on Windows, the login screen indicates an issue while attempting to establish a connection to the NetBackup Service Layer (NBSL).

 

Error Message

NetBackup Administration Console (popup):
Could not connect to NetBackup Service Layer. You may not be able to perform the functions in the Administration Console that depends on connectivity to this service. Please ensure the nbsl service is up and running.

This message is displayed at the bottom of the login screen:

Connecting NetBackup Service Layer...

After clicking on OK from the first message, this second message may be displayed:

Backup Policy Management (popup):
Could not get Class_att_defs information: A connection to <server_hostname> could not be established. Verify services or daemons are up and running.
You will not be allowed to change NetBackup policy attributes for server '<server_hostname>'.

The NetBackup Admin Console failed to establish a secure connection with the host "master.xyz.com"
The request was terminated with error code VRTS-24604.

Cause

The Java Administration Console shortcut/application was not being ran with "Run as Administrator" privileges.

 

Troubleshooting: Launching the Command Prompt (cmd.exe) and verify the text in the titlebar.

If it only says, "Command Prompt", then it is not running with Administrator privileges.

Windows Command Prompt without Administrator privileges

If it says, "Administrator: Command Prompt", then it is running with Administrator privileges.

Image

Note: Running the Java Administration Console batch file (e.g. C:\Program Files\Veritas\Java\nbjava.bat) from the 'Command Prompt' and/or 'Administrator: Command Prompt' may allow the session log to be visible at a glance and may show any errors at the time of failure.

 

Solution

Recommend running the Java Administration Console with 'Run as Administrator' privileges.

Note: If issues with NBSL persist, there may be another issue, suggest opening a case with Support.

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