Problem
After adding Google Cloud Platform credentials into CloudPoint, disk resources are not showing up
Error Message
From the flexsnap-agent log found in the /cloudpoint/logs folder:
Feb 21 17:09:40 5a2db6c7770c flexsnap-agent[1] flexsnap.agent: ERROR - Base Exception in loading plugin name gcp, config id gcp.<someguid>, error [('PEM routines', 'PEM_read_bio', 'no start line')],
Traceback (most recent call last):
File "/opt/VRTScloudpoint/lib/flexsnap/agent.py", line 224, in load_plugins
plugins = mod.load_plugin(tconf, tools_dir)
File "src/gcp/gcp.py", line 1317, in load_plugin
File "src/gcp/gcp.py", line 1024, in __init__
File "/tmp/cloudpoint/libs/gcp/lib/oauth2client/service_account.py", line 253, in from_json_keyfile_dict
revoke_uri=revoke_uri)
File "/tmp/cloudpoint/libs/gcp/lib/oauth2client/service_account.py", line 185, in _from_parsed_json_keyfile
signer = crypt.Signer.from_string(private_key_pkcs8_pem)
File "/tmp/cloudpoint/libs/gcp/lib/oauth2client/_openssl_crypt.py", line 116, in from_string
pkey = crypto.load_privatekey(crypto.FILETYPE_PEM, parsed_pem_key)
File "/usr/local/lib/python2.7/dist-packages/OpenSSL/crypto.py", line 2729, in load_privatekey
_raise_current_error()
File "/usr/local/lib/python2.7/dist-packages/OpenSSL/_util.py", line 54, in exception_from_error_queue
raise exception_type(errors)
Error: [('PEM routines', 'PEM_read_bio', 'no start line')]
Cause
This is the result of an invalid credential. In this case the private_key was incorrect.
Solution
Review the jsom created for the service account and input the credentials correctly. On a side note, verify the private_key used does not have "\n". When you look at the created jsom file, in a basic text editor, each line of the private_key ends with \n. You must replace each instance of \n with an actual carriage return.