Getting "A digitally signed driver is required." error when you install NetBackup 8.0 on a Windows platform with Secure Boot enabled.

Article: 100034311
Last Published: 2017-08-14
Ratings: 1 0
Product(s): NetBackup

Problem

If you install NetBackup 8.0 on a Hyper-V Generation 2 Windows Server 2016 Virtual Machine with secure boot enabled, you will receive the following error:

Allows granular display of back ups.
Veritas Technologies LLC

A digitally signed driver is required. Windows blocked the installation of a digitally unsigned driver. Uninstall the program or device that uses the driver and check the publisher's website for a digitally signed version of the driver.
 

Error Message

The following error may be visible in the Windows Event Viewer System log.

Source: Service Control Manager
Date: <date>
Event ID: 7000
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <name>
Description:
The Virt File service failed to start due to the following error:
Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.

 

Cause

The error message is issued during NetBackup 8.0 installation because Windows cannot verify the digital signature of VirtFile.sys.

Windows platforms other than Hyper-V Generation 2 Windows Server 2016 Virtual Machine may also have this issue if Secure Boot is enabled.

Solution

Veritas Technologies LLC has acknowledged that the above-mentioned issue (Etrack 3910851) is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers. The formal resolution for this issue is scheduled to be included in the following release:
NetBackup 8.1

Please note that Veritas reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas' plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Workaround:
Please contact Technical Support to obtain the hotfix.

Hotfix information:
Veritas Bug ID: ET 3910851
Version: NetBackup_8.0

Installation Instructions:
Please follow the EEB Installer instructions available on https://www.veritas.com/docs/000035801

References

Etrack : 3910852

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