VMware restore to a managed vSphere (ESXi) host fails with "A communications failure"

Article: 100034158
Last Published: 2017-06-13
Ratings: 1 0
Product(s): Backup Exec

Problem

When attempting to restore a virtual machine (VM) to a managed vSphere (ESXi) host, the restore fails with the below error messages.

Error Message

Final error: 0xe00084f9 - A communications failure has occurred between the Backup Exec job engine and the Agent for Windows.
Final error category: Resource Errors
 
Restore- VMVCB::\\HOSTNAME\VCGuestVm\ha-datacenter\vm\VM NAME
Error writing file data.

Cause

VMware blocks the creation of virtual machines on vSphere (ESXi) hosts which are managed by vCenter. This prevents you from directly restoring virtual machines to managed vSphere (ESXi) hosts.

Solution

Add the vCenter server to the list of servers, and run a redirected restore or an instant recovery job with the target set to that server. To add a VMware vCenter Server or ESX/ESXi host to the list of servers on the backup and restore tab, follow these steps:

  1. On the Backup and Restore tab, in the Servers and Virtual Hosts group, click Add.
  2. Select VMware vCenter server or ESX host, and then click Next.
  3. Select Add a VMware vCenter server or ESX host to the list of servers.
  4. Enter the name or IP address of the server you want to add, and then add an optional description of the server.
  5. If you want Backup Exec to install the Agent for Windows on any guest virtual machines for this host server, verify that the option After adding the virtual host, install the Backup Exec Agent for Windows on the guest virtual machines is selected. To perform Granular Recovery Technology (GRT)-enabled backups of the Microsoft applications that are installed on the virtual machines, the Agent for Windows must be installed on the guest virtual machines. If you do not want to install the Agent for Windows on the guest virtual machines, clear the check box. You can install the Agent for Windows later if you decide that you want to use GRT.
  6. Click Next.
  7. Select the correct logon account for the server from the drop-down list. If the logon account for the server is not in the list, click Add/Edit to add it to the list.
  8. Click Next.
  9. Review the summary information, and then click Finish.

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