Problem
When executing an Image Verify in the NetBackup GUI or by command line, the bpverify operation may fail (see Error Message below). The failure is likely to be intermittent and quite rare (due to condition #3 below). The problem may occur because of allocated memory that is not completely zeroed out before being used.The conditions needed for this error are:
1. Windows FS backup
2. A shared directory
3. The shared directory backup lines up with just the right garbage left over in memory
4. bpverify
This bpverify failure and subsequent error message may not indicate an actual problem with the image. To determine if there is a problem with the image, do a restore from the affected image. If the restore is successful, then the verify failure and error may be ignored. If the restore fails from that image, there may be an actual problem and that image will need further troubleshooting.
Error Message
The Activity Monitor --> Verify Detailed Status job will show errors such as the following:INF - Filename length does not match for file /H/dir01/dirabcd/, in image is 17, in database is 15.
INF - Filename from image (/H/dir01/dirabcd/) does not match filename in database (/H/dir01/dirxy/).
INF - File number does not match for file /H/dir01/dirabcd/, in image is 1168, in database is 1167.
INF - Block number does not match for file /H/dir01/dirabcd/, in image is 7403759, in database is 7403752.
INF - Compressed length does not match for file /H/dir01/dirabcd/, in image is 264, in database is 300.
INF - At least 10 database compare errors occurred, not logging anymore.
INF - There are more files in the database than are contained in the image on the media.
INF - There were 98 compare errors on this image.
INF - Verify of policy XYZ, schedule FULL (client1_1475514061) failed, the database contains conflicting or erroneous entries.
Note: Not necessarily all of these errors, and possibly others may be seen.
Cause
Internal memory that is not completely zeroed out contains just the right leftover garbage to cause conditions to add unexpected flag to tar header. On bpverify, the tar header is ignored because of this unexpected condition. This causes a mis-compare between the image and the database.
Solution
Veritas Technologies LLC is aware that the above-mentioned issue (Etrack 3905940) is present in the current version(s) of the product(s) mentioned in this article. Veritas is committed to product quality and satisfied customers.
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time. However, this particular issue is not currently scheduled for any release.
Please note that Veritas reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas' plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
As new releases are made available, please access the following link to download README information and determine if this issue has been resolved:
https://www.veritas.com/support/en_US/58991.html
Workaround:
The bpverify error can be ignored. Restores, imports, duplicates will work okay. The long term solution is to fix bpbkar32 issue on backups. No “fix” for existing affected backups is available.