NetBackup Vault job does not start on Windows master server. This issue occurs after installation of NetBackup security patch, VTS16-001, on 7.5.0.7 Windows master server

Article: 100032701
Last Published: 2016-07-08
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

A previously working configuration, however immediately after the installation of the NetBackup security patch,  VTS16-001, on a 7.5.0.7 a Windows master server and once a NetBackup Vault Session is started from NBconsole, it will not display the vault job in the Activity Monitor.

Example and log extract from the nbconsole log where a manual vault job was started.

05:51:50.358 [3584.6880] <4> CNBPVault CNBPVaultView->OnActionStartSession: /usr/openv/netbackup/bin/vltrun vltrun 0/MyVault/alan
05:51:50.358 [3584.6880] <4> CNBPVault CNBPVaultView->OnActionStartSession: The manual vault session for the profile has been started.

 

Error Message

Log extract from NetBackup bpcd log:
 
12:54:49.229 [1880.4556] <2> process_requests: BPCD_FORK_OTHER_CMD_RQST12:54:49.229 [1880.4556] <2> process_requests: fork cmd =  /usr/openv/netbackup/bin/vltrun vltrun 0/MyVault/alan12:54:49.229 [1880.4556] <2> is_path_whitelisted: PATH (C:\Windows\system32\vltrun  0\MyVault) is __NOT__ whitelisted.12:54:49.229 [1880.4556] <16> process_requests: illegal fork attempted

Cause

The NetBackup process,  bpcd, fails when it is requested to fork a request and will exit with reports: process_requests: illegal fork attempted which is preventing the vault job from being displayed in the NetBackup Activity Monitor.

Solution

Veritas Technologies LLC is aware that the above-mentioned issue (Etrack 3879885 ) is present in the current version(s) of the product(s) mentioned in this article. Veritas is committed to product quality and satisfied customers.  This issue was scheduled to be included in the following release:
  • NetBackup 8.0

When NetBackup 8.0 is available, please access the following link for download and README information:
  https://www.veritas.com/content/support/en_US/15143.html

Please note that Veritas reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas' plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Workaround:
An Emergency Engineering Binary (EEB) bundle containing a fix for this issue for NetBackup 7.5.0.7 is available by contacting Veritas technical support, referencing this document ID and Etrack 3879884 .

 

References

Etrack : 3879885

Was this content helpful?