Problem
OstDrv Tape Drives show up in the Storage Tab of Backup Exec. The issue can be the result of two Backup Exec servers backing up a particular remote server with client side deduplication in the Backup Job.
figure 1:
This can also result in the Backup Job not using Client Side Deduplication and completing with an exception.
figure 2:
Cause
When Client Side Deduplication is selected in the Backup Job, BackupExecServerHostname.CFG file gets created on the Remote server where client side is being enabled (at RAWS Install Path). This file acts as a reference for the Backup Exec remote agent enabling it to connect correctly and send the data directly to the Deduplication Storage Folder.
The Adamm.log (Located at BE Install Path\Logs folder) shows the correct entries for this server (remote server 4) whose backup was completing with client side exception :
figure 3:
On remote server 4 it was seen that an incorrect BackupExecServerName.CFG file existed. The file 001E6783FF82.cfg should not have been present. This Issue was seen when an Appliance was replaced and configured from scratch. The remote agent was allready Installed and started publishing to the Backup Exec Appliance which was given the same hostname as before.
figure 4:
Solution
1) Identify the remote server which is causing the Tape drive entries to appear incorrectly in the Backup Exec Console -> Storage Tab
Go to details of the Tape Drive and check the Port, Bus, Target ID and LUN address. Then look for this same address in the adamm log to identify the remote server (refer to figure 3 - remote server 4 scsi address. It matches the tape drive entries shown in figure 1)
2) Disable and delete the Tape Drive entries which show as OstDrv.
3) Go to the Backup and Restore Tab. Highlight the remote server and then go to Details -> Direct access sharing Tab and deselect the checkbox which shows the deduplication storage is shared with this remote server. Save the changes by clicking OK.
4) On the remote server check if a CFG file with the wrong BEservername was created. If this is the case, rename that CFG file (then restart the Backup Exec Remote Agent Service) and save the Client Side enabled backup job on the BE Server or re-select the sharing checkbox in the direct access sharing tab. This action will require you to restart the BE services on the Backup Exec Server. After the restart of the BE services the correct BEServerName.CFG file will get created and this then should not result in multiple tape drive (OSTDrv) entries appearing in the BE Storage Tab.
Note: Restarting the BE services initiates the device discovery process which helps to check the devices connected to the Backup Exec (local storage) and remote servers (in case of RMAL or Client Side Dedupe). A review of the adamm.log can help to narrow down any problems with the device discovery taking longer than usual.
Note: The file should not be renamed if the name of the file is the same as the current Backup Server.
It is also recommended that the remote server should be backed up from only a specific backup exec server if client side deduplication is enabled. If more than one backup exec server have jobs configured with client side and are backing up the same remote server then these fake tape drive entries appear on the second BE server.