NetBackup duplications fail with status 12

Article: 100031772
Last Published: 2022-01-10
Ratings: 1 1
Product(s): NetBackup & Alta Data Protection

Problem

Backup to disk, Duplication to Tape

The problem is that duplications are waiting for the tape drives for about 3 days. When the tape drive becomes available the BID file for the duplication is no longer found.

11/11/2015 23:59:03 - requesting resource JMP_All_Drives
11/11/2015 23:59:14 - Info nbrb (pid=29567) Limit has been reached for the logical resource JMP_All_Drives
11/15/2015 11:46:54 - granted resource  JMP_All_Drives
11/15/2015 11:46:55 - started process RUNCMD (pid=21743)
11/15/2015 11:46:56 - ended process 0 (pid=21743)
11/15/2015 11:46:56 - begin Duplicate
11/15/2015 11:46:57 - Error bpduplicate (pid=21743) cannot open /usr/openv/var/global/nbstserv/bid_file_jz_14473079xx_28_28, No such file or directory
11/15/2015 11:46:57 - end Duplicate; elapsed time 0:00:01
file open failed  (12)

Cause

The duplication jobs that fail are started but stay queued for 3 or 4 days as the tape drives are in use.

When the tape drives become available it is found that the batch id BID file for the duplication is no longer available. It has been cleaned up after a period of time shorter than the period of queuing for the jobs.
 

Solution

To resolve this issue run the following on the Master server:

UNIX Master server:

1.  /usr/openv/netbackup/bin/admincmd/bpsetconfig
2.  bpsetconfig> SLP.BIDFILE_CLEANUP_DELAY = 5
3.  Hit Enter to submit
4.  <ctl-D> to exit.

 

Windows Master server:

1.  <install path>\veritas\netbackup\bin\admincmd\bpsetconfig
2.  bpsetconfig> SLP.BIDFILE_CLEANUP_DELAY = 5
3.  Hit Enter to submit
4.  Press Ctrl+Z

5. Enter to save and exit

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