Restore job failing with error status: 2110, EMM status: Requested machine is not configured in NetBackup and allocation failed (10)

Article: 100031668
Last Published: 2015-12-09
Ratings: 0 0
Product(s): NetBackup

Problem

The restore of a client is failing, with error status 2110 followed by exit status 10, when a load balancing media server is used to do the restore.

Error Message

Restore Job Detailed Status (via Administration Console)
11/10/2015 13:28:50 - begin Restore11/10/2015 13:28:50 - restoring from image client_144685085111/10/2015 13:28:50 - Warning bprd (pid=24336) Restore must be resumed prior to first image expiration on Mon 07 Dec 2015 06:00:51 PM EST11/10/2015 13:28:51 - requesting resource @aaaan11/10/2015 13:28:51 - Error nbjm (pid=4068) NBU status: 2110, EMM status: Requested machine is not configured in NetBackup11/10/2015 13:28:51 - Error nbjm (pid=4068) NBU status: 2110, EMM status: Requested machine is not configured in NetBackup11/10/2015 13:28:51 - end Restore; elapsed time 0:00:01allocation failed  (10)

Restore Task Progress Results (via Backup, Archive, and Restore)
Restore Job Id-11039407Restore started 11/10/201513:28:51 (11039407.001) Status of restore from copy 1 of image created Fri 06 Nov 2015 06:00:51 PM EST = allocation failed13:28:51 (11039407.001) The following files/folders were not restored: 13:28:51 (11039407.001) UTF - /vol/advdisk/savedir/OST-Stuff.log13:28:51 (11039407.xxx) INF - status allocation failed. 

Cause

There is a Media Host Override entry in place which is preventing the original backup Media Server from performing the restore.

Solution

1. Find the image in the Catalog.
2. Determine which media server is associated to the image as the backup media server (this can be achieved from under ' Catalog ' in the NetBackup GUI, or if the backup ID is known, look for " Host: " in the output of ' /usr/openv/netbackup/bin/admincmd/bpimagelist -backupid <client_ctime> -L '  (Windows: <installPath>\VERITAS\NetBackup\bin\admincmd\bpimagelist).
3. Check for a Media Host Override entry in Master Server > Host Properties > General Server.
4. Remove the Media Host Override entry which contains the backup Media Server as the Original Backup Server value.
5. A restart of the NetBackup processes/services will be required for the change to take affect.
6. Re-run the restore. It should now complete successfully.

Workaround:

If you are unable to remove the Media Host Override entry:
Create the touch file USE_BACKUP_MEDIA_SERVER_FOR_RESTORE on the NetBackup master server in the following directory:
 
UNIX\Linux: /usr/openv/netbackup/db/config
Windows: <installPath>\VERITAS\NetBackup\db\config

NOTE: This global setting always forces restores to the server that did the backup. It applies to all NetBackup restore jobs, not just deduplication restore jobs. If this touch file exists, NetBackup ignores the FORCE_RESTORE_MEDIA_SERVER and FAILOVER_RESTORE_MEDIA_SERVER settings.

Was this content helpful?