A restart from a previous installation prevents Enterprise Vault from installing

Article: 100031403
Last Published: 2019-05-09
Ratings: 0 0
Product(s): Enterprise Vault

Problem

In Enterprise Vault 11.0.1 or later, a pending system restart request persists even after restarting the computer. This prevents Enterprise Vault from installing.

Error Message

Enterprise Vault attempts to discover which application is requesting the system restart and displays the following message:

"A restart from a previous installation of <application> is pending.
You must restart the computer to complete this previous installation
before you run the Enterprise Vault installation.
See the log for more information
."


  • In the installation log file, you may also see the following: 

ERROR: Pending reboot detected in registry key : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

ERROR: Value : "C:\PROGRA~2\InstallShield Installation Information\{7042DC99-7779-4C5C-A7F2-B9957BFA04EC}\setup.exe" -reboot"C:\PROGRA~2\InstallShield Installation Information\{7042DC99-7779-4C5C-A7F2-B9957BFA04EC}\reboot.ini" -l0x0009


Cause

For certain software installations, reboot is mandatory post installation is completed.
This reboot request is added to the registry in Windows O.S. 
Ideally, post-reboot, the request from registry should get cleaned out but sometimes, it doesn't get removed. Due to this, Enterprise Vault Installation gets interrupted.

Solution

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.  
  1. If a system restart is pending, restart the computer.
  2. If the pending system restart requests persists after the restart, then go to start - regedit and navigate to the following location:

32 Bit O.S.:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

64 Bit O.S.:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\RunOnce

  1. If there is a pending restart key under this setting, remove the pending restart key. If there is a "InstallShieldSetup" string, delete it.
  2. Go to: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\KVS\Enterprisevault\Install. Delete the string: PendingReboot
  3. Try to re-initiate the Enterprise Vault installation.

If the issue still persists, please contact Veritas Technical Support by creating a support case OR by reaching our customer care team at one of our Global Support Numbers for further investigation.

References

Etrack : 3855576

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