Enterprise Vault Office Mail App fails to initialize due to incorrectly defined URL of the EWS virtual directory

Article: 100031398
Last Published: 2023-04-07
Ratings: 0 1
Product(s): Enterprise Vault

Problem

Enterprise Vault (EV) Office Mail App does not load in Outlook with the error Initialization failed.

Error Message

User-added image

Additionally, in a Fiddler trace when the host makes this call “/owa/service.svc?action=ExecuteEwsProxy” the following error occurs:
 
{"Body":null,"ErrorMessage":"The remote server returned an error: (401) Unauthorized.","StatusCode":0,"StatusDescription":null,"WasProxySuccessful":false}
 

Cause

The proxy to the Exchange Mailbox server was failing because the internal URL of the EWS virtual directory was set to the external URL instead of the Exchange Mailbox server.  

Solution

Update the internal URL in the Exchange Admin Center to be the Exchange Mailbox Server:
 
  1. Disable users that have been enabled with the EV Office Mail App
  2. Log into the Exchange Admin Center
  3. Go to Servers
  4. Go to Virtual Directories
  5. From the dropdown menu select the following:
 
Select Server: < Exchange_Mailbox_Server_Name>
Select Type: EWS
 
  1. Edit the EWS (Default Web Site) of the Exchange Server
  2. On the General tab update the Internal URL to be: FQDN_of_Exchange_Server/EWS/Exchange.asmx
  3. Re-enable users with the EV Office Mail App 

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