Import via PST resets creation date and messages are not archived by Enterprise Vault (EV).

Article: 100029477
Last Published: 2014-08-06
Ratings: 1 0
Product(s): Enterprise Vault

Problem

Import via PST resets creation date and messages are not archived by Enterprise Vault (EV).

Cause

When a mailbox is restored from a PST, the creation date on the messages is reset and EV will not archive the items as they do not fall into the archiving criteria. Dtrace of the Archive Task process (Archivetask) will show a check if the item is eligible for archival.

Note:  See Related Documents for details on using Dtrace.

Example of Dtrace:

(ArchiveTask) <2792> EV:L :CArchivingAgent::IsEligibleForArchive(/o=NTC/ou=First Administrative Group/cn=Recipients/cn=User1) |The message titled: Re: Test Email will not be archived as its inactivity period has not expired  |
(ArchiveTask) <2792> EV:H :CArchivingAgent::IsEligibleForArchive() |Exiting routine

Solution

The creation date of the message being reset is carried out by third party software and out of EV's control.  In order to archive the item adjust or change the "Mailbox Archiving Policy" to reflect the creation date of these messages. Setting an archive policy of 0 days or archive immediately will ensure that the messages meet the required criteria.
 
Once the affected messages are archived by the 0 day policy assign the original Mailbox policy to the user.

If it is necessary to affect a group of users, or a single user, perform the following:
 
  1. Create a copy of the current policy.
  2. Change the copied policy to reflect the new archiving rules.
  3. Create a Provisioning group for that policy.
  4. Assign the necessary users to the Provisioning group.
  5. Run the Provisioning Task to associate the new users to the new Policy to ensure only the necessary mailboxes are affected.
  6. Run The Mailbox Archiving Task to archive the users utilizing the new Policy Archiving rules.

 

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