Problem
After upgrading Enterprise Vault to version 10.0.3 or above the indexing service will not start and a 40966 event is logged as below:
Error Message
Event ID: 40966
Category: Index Admin Service
A program fault has raised an exception.
Exception: Category does not exist.
Diagnostic:
Type: System.InvalidOperationException
Reference:
Command Line: "C:\Program Files (x86)\Enterprise Vault\EVIndexAdminService.exe" -EntryID:1649F3834152EE247B624A8FB152ADE701710000VaultSite
Application Domain: EVIndexAdminService.exe
Process Id: 3880
Thread Id: 5624
Stack Trace: at System.Diagnostics.PerformanceCounterLib.CounterExists(String machine, String category, String counter)
at System.Diagnostics.PerformanceCounter.Initialize()
at System.Diagnostics.PerformanceCounter.NextSample()
at System.Diagnostics.PerformanceCounter.NextValue()
at Symantec.EnterpriseVault.Indexing.Admin.IVSchemaUpgrade.VolumeProcessing.WorkerThreadRoutine(Object threadParams)
at System.Threading.ExecutionContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart(Object obj)
V-437-40966
Cause
This is caused by a corrupted performance counter. As of EV 10.0.3 a check is performed on the Memory - Committed Bytes In Use performance counter, when upgrading the index volume schema. If this counter is missing due to corruption, then this issue will be present.
Solution
To check that this particular issue is present:
- On the EV server in question, run performance monitor via the perfmon.exe command.
- Click on the Add Counters icon.
- Scroll down the list of available categories and if Memory is missing, then this issue is present.
There is the following Microsoft article outlining how to manually rebuild performance counters:
https://support.microsoft.com/kb/2554336
Veritas does advise that Microsoft be contacted to confirm the best course of action before running through the article.
Applies To
EV 10.0.3 or above