Enterprise Vault (EV) 10 Indexing Service could not complete all the required startup routines

Article: 100028650
Last Published: 2021-10-01
Ratings: 0 0
Product(s): Enterprise Vault

Problem

The Enterprise Vault 10 Indexing Service could not complete all the required startup routines and therefore fails to start.

Error Message

Following event is generated while trying to start the Indexing service.

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Event ID:      41312
Task Category: Index Admin Service
Level:         Error
Keywords:      Classic
User:          N/A
Description:   The Indexing Service could not complete all the required startup routines: The account that this Service is running under is not a member of the local IIS_IUSRS group on this computer. Service will be stopped.
V-437-41312

DTrace of the EVIndexAdminService shows the following: 

(EVIndexAdminService) <8132> EV-L {SERVICEBASEEX.EN_US} Starting Indexing Service ...
(EVIndexAdminService) <8132> EV-H {SERVICEBASEEX.EN_US} Starting service background thread for Indexing Service.
(EVIndexAdminService) <8132> EV-H {SERVICEBASEEX.EN_US}  Started service background thread Id:6 for Indexing Service.
(EVIndexAdminService) <8132> EV-L {SERVICEBASEEX.EN_US} Start up grace time [120000 ms]
(EVIndexAdminService) <8132> EV-H {SERVICEBASEEX.EN_US} Waiting for some more time for Indexing Service to start. Start time[11:13:02], Log Time[11:13:02], Elapsed Time[00:00:00 ms]
(EVIndexAdminService) <912> EV-L {SERVICEBASEEX.EN_US} Starting Indexing Service startup/initialization routines in a background thread
(EVIndexAdminService) <912> EV-L {SERVICEBASEEX.EN_US} Executing OnPerformStartup()
(EVIndexAdminService) <912> EV-L {INDEXADMINSERVICE.EN_US} Starting Index Admin Service startup routines in a background thread
(EVIndexAdminService) <912> EV-L {INDEXADMINSERVICE.EN_US} Indexing service startup pre-reqs started
(EVIndexAdminService) <912> EV-L {STATEMANAGER.EN_US} Checking if current user has administrator rights.
(EVIndexAdminService) <912> EV-L {STATEMANAGER.EN_US} Current user has administrator rights.
(EVIndexAdminService) <912> EV-M {STATEMANAGER.EN_US} Local Dir Entry String = WinNT://EV01SERVER,computer
(EVIndexAdminService) <912> EV-M {STATEMANAGER.EN_US} Domain Dir Entry String = WinNT://EXAMPLE
(EVIndexAdminService) <8132> EV-H {SERVICEBASEEX.EN_US} Waiting for some more time for Indexing Service to start. Start time[11:13:02], Log Time[11:13:02], Elapsed Time[00:00:02.0123871 ms]
(EVIndexAdminService) <912> EV-H {STATEMANAGER.EN_US} Exception: The RPC server is unavailable.| Info: Diag:HRESULT: 800706ba Type:System.Runtime.InteropServices.COMException ST:   at System.DirectoryServices.DirectoryEntries.Find(String name, String schemaClassName)|   at Symantec.EnterpriseVault.Indexing.Admin.StateManager.AddVSAToIIS_IUSRSGroup() Inner:None
(EVIndexAdminService) <912> EV-H {INDEXADMINSERVICE.EN_US} The Indexing Service could not complete all the required startup routines: The account that this Service is running under is not a member of the local IIS_IUSRS group on this computer. Service will be stopped.
(EVIndexAdminService) <912> EV~E |Event ID: 41312 The Indexing Service could not complete all the required startup routines: The account that this Service is running under is not a member of the local IIS_IUSRS group on this computer. Service will be stopped.
(EVIndexAdminService) <912> EV-H {SERVICEBASEEX.EN_US} Exception of type 'KVS.EnterpriseVault.Common.ServiceBaseExException' was thrown.

Cause

1. This issue occurs when the Enterprise Vault Service account (VSA) is located in one Windows domain and the Enterprise Vault server is located in a different Windows domain.

2. Windows Process Activation Service is not running. This can be checked in Windows Services or by typing iisreset /status command at a DOS prompt.

 

Solution

Workaround:

Add the DNS suffix of the Windows domain where the VSA resides to the network configuration in the Enterprise Vault server.  There currently is no permanent solution to this issue.

If Windows Process Activation Service is not running it is best to try and reapply the latest EV binaries. If using CHF then reapply CHF. If not using CHF then reapply EV install binaries. To do this it is recommended to set all EV Services to disabled, restart server, install the appropriate binaries and then restart the server again. Check if Windows Process Activation Service is running. If not, then try to manually start the service. If this works then make sure Net.Tcp Listener Adapter, Net.Pip Listener Adapter, and World Wide Web Publisher Service services are running. If those services are all running then try to start the Enterprise Vault Indexing Service.

 

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