V-79-57344-34070 - Backup of Microsoft Exchange Database Availability Group (DAG) fails with error "Snapshot provider error (0xE0008516): Resources specified for snapshot do not have any valid data on them.

Article: 100028422
Last Published: 2023-12-01
Ratings: 0 0
Product(s): Backup Exec

Problem

Backup of Microsoft Exchange Database Availability Group (DAG) using Backup Exec fail with error "Snapshot provider error (0xE0008516): Resources specified for snapshot do not have any valid data on them. Check if files were deleted or renamed".

Error Message

V-79-57344-34070 - AOFO: Initialization failure on: "Microsoft Information Store". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).
Snapshot provider error (0xE0008516): Resources specified for snapshot do not have any valid data on them. Check if files were deleted or renamed.

Cause

If the Windows Backup tool was used to backup the Exchange DAG, as part of setting up the Windows Backup tool, the following registry value must be created to  work in a database availability group (DAG) .

NOTE:  Incorrectly editing the registry can cause serious problems that may require you to reinstall your operating system. Problems resulting from editing the registry incorrectly may not be able to be resolved. Before editing the registry, back up any valuable data.

HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\Replay\Parameters. 
DWORD value: EnableVSSWriter
Value:

 

Microsoft documentation used to enable Windows Backup feature states that the Microsoft Exchange Replication server VSS writer must be disabled for correct operation.  However, to use Backup Exec after having run a Windows Backup, the registry key "HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\Replay\Parameters\EnableVSSWriter" must be re-enabled by setting the value to 1 (default), and the Microsoft Exchange Replication service must be restarted to enable the 'Microsoft Exchange Replica Writer' again.
 

Reference:

Using Windows Server Backup to Back Up and Restore Exchange Data

http://technet.microsoft.com/en-us/library/dd876851(v=exchg.141).aspx

"Using Windows Server Backup on Database Availability Group Members. If a server hosting the data being backed up is a member of a Database Availability Group (DAG) and hosts both active and passive database copies, you must disable the Microsoft Exchange Replication service VSS writer. If the Microsoft Exchange Replication service VSS writer is enabled, the backup operation will fail."

The article also includes an * Important* note at the bottom which states:
"Important If you later want to use a different backup solution to back up passive database copies on a server that has the Microsoft Exchange Replication service VSS writer disabled, you need to remove the preceding registry key and then restart the Microsoft Exchange Replication service ."

 

Solution

Set the value for the below EnableVSSWriter value 1 (default).

HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\Replay\Parameters. 
DWORD value: EnableVSSWriter
Value: 1

Restart the Microsoft Exchange Replication service to enable the 'Microsoft Exchange Replica Writer'.

 

Note: The above registry is for Exchange 2010. For Exchange 2013 or later versions, the registry key is under HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v15. Select the registry depending on the Exchange version. 

 

 

 

References

UMI : V-79-57344-34070

Was this content helpful?