NetBackup for Microsoft Exchange backups fail with Status Code 13 and "Exchange Validation" failure

Article: 100027680
Last Published: 2018-12-13
Ratings: 0 2
Product(s): NetBackup & Alta Data Protection

Problem

NetBackup for Microsoft Exchange backups fail with Status Code 13 and detailed status shows failure"Exchange Validation for 'Microsoft Information Store:\database' failed".

Error Message

09/10/2012 11:06:54 - Error bpbrm (pid=12405) from client exchangeserver: ERR - Terminating backup.
09/10/2012 11:06:54 - Error bpbrm (pid=12405) from client exchangeserver: ERR - failure reading file: Microsoft Information Store:\Storage group\Mailbox database (BEDS 0x0: )
09/10/2012 11:06:54 - Warning bpbrm (pid=12405) from client exchangeserver: WRN - Exchange Validation for 'Microsoft Information Store:\Storage group\Mailbox database' failed.  Please refer to the backup and application event logs for more details.
file read failed  (13)

You may find an unsuccessful consistency check on the Microsoft Exchange database in the bpbkar log. If the consistency check option is not selected in the client host properties, the bpbkar log will show that either a data file such as the .edb file was not completely read (fewer bytes than expected were read), or a data file was not found.

The failure may be intermittent. It is more likely to occur when the e-mail system is very active, or when there is a long time between the start of the snapshot job and the completion of the backup job.

Cause

This failure occurs when the Windows operating system deletes the snapshot, which can be due to insufficient disk space being configured for the snapshot.

Solution

A snapshot using the VSS "system" provider is copy-on-write. It starts small when the snapshot is taken. Whenever data is written to the Exchange database, the system provider copies the original unchanged block to the snapshot space. The snapshot then grows as more data is written.

Use vssadmin to check the space assigned for snapshots of the disk volumes that hold the Exchange data. If the snapshot size limit is set to "unlimited," make sure the target volume itself has enough space to hold the snapshot.

Applies To

This problem applies to all versions of NetBackup and Microsoft Exchange, as it is not a bug in either product. It is caused by a faulty VSS snapshot configuration.

The Event Viewer may may show events such as the following in the Application log:
Log Name:      Application
Source:        Storage Group Consistency Check
Date:          9/13/2012 11:29:52 AM
Event ID:      401
Task Category: Termination
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Exchange server
Description:
Instance 1: The physical consistency check has completed, but one or more errors were detected. The consistency check has terminated with error code of -106 (0xffffff96).


Log Name:      Application
Source:        Storage Group Consistency Check
Date:          9/12/2012 11:57:49 AM
Event ID:      403
Task Category: Termination
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Exchange server
Description:
Instance 1: The physical consistency check successfully validated 16117998 out of 28878712 pages of database '\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy27\Mailbox Database.edb'. Because some database pages were either not validated or failed validation, the consistency check has been considered unsuccessful.

 

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