Problem
Drives unavailable within NBU on a Media Server
Robot Detected, but no drives detected
Drives visible in windows device manager
Error Message
Tape drives showing MISSING_PATH
Cause
Driver Issue on W2003
This was illustrated to the customer by starting the RSM service and trying to access the drives within the RSM applet.
The drives were visible but had a red X against them
The drives (IBM LTO3) were using the SAME drivers that were fine on the master server, and device mappings file 1.99
Solution
Replaced IBM driver with generic LTO driver
At this point scan could see the drive (tested with just one drive)
Update Driver
Dont use windows update
Select from list
uncheck 'show compatible drivers'
browse to LTO on the left pane and generic LTO on the right
install
There is a w2003 MS KB regarding IBM lto drrives
https://support.microsoft.com/kb/941140
This is a likely cause as it may explain the same drivers working on the Master Server
Or on a 32 bit system you can use Veritas drivers also:
https://www.veritas.com/docs/000033133
Alternatively the latest IBM drivers may also have worked
Applies To
Windows 2003 x86
Netbackup 7.0.1