Backups to an HP LTO tape drive are getting less than the stated native capacity of each tape

Article: 100026089
Last Published: 2014-07-25
Ratings: 0 0
Product(s): Backup Exec

Problem

Backups using an HP LTO tape drive are getting less data than the native capacity specified for each tape.

 

Cause

Each generation of LTO  media has a specified native capacity.  For example, LTO-4 tapes are listed ast 800 GB / 1600 GB media.  The smaller number used in the marketing of the drive is the native capacity. The native capacity of LTO-4 tapes is therefore 800 GB.  Backups should be able to fit at least 800 GB of data on the media even if the compression ratio is 1:1.  

 

If only 600 GB or less is fitting on an LTO-4 tape, that is usually an indication of a faulty tape drive.   

 

Native Capacity for each Generation of LTO tapes
  LTO-1   100 GB
  LTO-2   200 GB
  LTO-3   400 GB
  LTO-4   800 GB
  LTO-5   1.5 TB
  LTO-6   2.5 TB

 

 

 

 

 

 

 

 

 

 

 

 

Solution

HP provides a utilty called Library and Tape Tools which can test the health of the tape drive.  This utility can test if the tape drive is meeting specifications for the amount of tape taken up by a specific amount of data:

 

1.  Stop all Backup Exec Services

 

2.  Download and install the HP  Library and Tape Tools:

https://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=406731&locale=en_US&taskId=135&prodSeriesId=406729&prodTypeId=12169

 

 

3.  Load a tape into the tape drive.  If the tape drive is part of a tape library, a tape will need to be manually moved from a slot to the drive using the library's user interface.

Note: The tape inserted into the drive will be overwritten by the test.  Confirm the tape to be used does not contain any data that may be needed in the future as any data on the tape will no longer be available after the test runs.

 

4.   Open the HP  Library and Tape Tools

 

5.  Load the LTO  Drive Assessment Test.  Go to the Options screen of the test and make the following changes:  

Set Allow Overwrite to "True"

Set Test Coverage to "4x". 

 

6.  Run the test

 

The test will run and generate a report.  Any failures will be indicated by STOP signs.  If any failures are seen, the tape drive vendor should be contacted.

 

The test writes to the tape in both directions, forward and backward.  It analyzes how much data it was able to write to tape and then compares that value to how much data the drive was designed to write for that same amount of tape.  This gives the "effective capacity" the drive is currently able to achieve expressed as a percentage of the maximum value.  That means a drive showing 100% effective capacity would get the maximum data physically possible on each tape.  A drive showing a 50% effective capacity would only be able to write 1/2 the amount of data to a tape compared with the maximum possible value listed for the tape's native capacity.  

 

This "effective capacity" is then normalized to a "Margin" value such that 100% margin would indicate a drive working to the maximum design specs, and a 0% margin would be the bare minimum value to consider the drive to be "working".  So 0% is the minimum "pass" value of the test.  Anything below 0% for the "Overall Drive Margin" is a "fail" value and indicates a drive that is considered faulty.

 

If there are any failures indicated in the logs from the test, the tape drive vendor should be contacted for replacement options.  

 

The HP Library and Tape Tools User Guide clearly defines that if there are failures during the drive assessment test, the tape drive is faulty:

 

The LTO drive assessment test is the most important test in the L&TT diagnostics suite because it is used to assess the health of a tape drive, providing a clear pass/fail result in about 15 minutes. If the test reports that the drive is good, the user can be confident that the drive is working as advertised and is not the cause of any backup or restore issues in the system. If the test fails, HP support will accept that assessment without further diagnostics, making this a key test for both end users and HP support. 

If in doubt, run the L&TT Drive Assessment test with a trusted (or new) tape. This is the test approved by HP support to give the most accurate assessment of drive health. If a drive passes this test, it is considered to be good. If it fails (and the tape is good), then HP support will exchange the drive.

 


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