Unable connect to JAVA console because Private Branch Exchange (PBX) port 1556 was changed.

Article: 100024931
Last Published: 2013-10-04
Ratings: 1 0
Product(s): NetBackup & Alta Data Protection

Problem

Unable to launch JAVA console because Private Branch Exchange (PBX) port was changed from the default port 1556 to another port. The reason PBX port was changed is that another application already used port 1556 on the same system.

Error Message

If PBX port is changed, other NetBackup programs are still trying to connection to PBX  port 1556.

Change of PBX port is NOT supported.

Example from logs:

admin log:

12:43:44.470 [3885] <2> bpstsinfo: SetLogger started GetNBLogger()(../bpstsinfo.cpp:514)
12:43:44.472 [3885] <2> bpstsinfo: INITIATING /usr/openv/netbackup/bin/admincmd/bpstsinfo -UPDATE (../bpstsinfo.cpp:330)
12:43:44.472 [3885] <2> vnet_same_host: ../../libvlibs/vnet_addrinfo.c.2915: 1: name2 is empty: 0 0x00000000
12:43:44.479 [3885] <4> db_getSTUNITlist: emmserver_name = xxxxxx
12:43:44.479 [3885] <4> db_getSTUNITlist: emmserver_port = 1556
12:43:44.502 [3885] <2> Orb::setDebugLevelFromVxul: Orb logging configuration level set to 0(../Orb.cpp:2254)
12:43:44.505 [3885] <2> SetMaxFileNum: current max fileno: 1024, max fileno hard limit: 65536(../../libutil/SetMaxFileNum.cpp:33)
12:43:44.505 [3885] <2> SetMaxFileNum: successfully set max fileno: current=8192, max=8192(../../libutil/SetMaxFileNum.cpp:89)
12:43:44.513 [3885] <2> Orb::setDebugLevelFromVxul: Orb logging configuration level set to 0(../Orb.cpp:2254)

bptm log:

12:38:45.583 [3696] <2> bptm: INITIATING (VERBOSE = 5): -delete_all_expired
12:38:45.584 [3696] <2> bptm: PORT_STATUS = 0x00000000
12:38:45.584 [3696] <2> vnet_same_host: ../../libvlibs/vnet_addrinfo.c.2915: 0: name2 is empty: 0 0x00000000
12:38:45.585 [3696] <4> bptm: emmserver_name = xxxxxx
12:38:45.585 [3696] <4> bptm: emmserver_port = 1556
12:38:45.622 [3696] <2> vnet_cached_getaddrinfo_and_update: ../../libvlibs/vnet_addrinfo.c.1514: 0: found in file cache name: NULL
12:38:45.622 [3696] <2> vnet_cached_getaddrinfo_and_update: ../../libvlibs/vnet_addrinfo.c.1515: 0: found in file cache service: veritas_pbx

Cause

Change of PBX port is NOT supported.

 

PBX port is a common configuration across hosts/tiers and Symantec products. PBX is the bottom most layer within NetBackup for
communication across all hosts and from pre-install to post-uninstall stages.

Solution

Do not attempt to change PBX port because there are number of Netbackup programs using port 1556 as the default port.  Port 1556 is hard coded.

Please refer to this Article for details on the assigned port for PBX.

The PBX port (1556) is assigned to Veritas/Veritas by IANA:

https://www.iana.org/assignments/port-numbers

Change of PBX port is not supported.


Applies To

Solaris 10 running NetBackup 7.0.1, 7.1

References

Etrack : 2416931

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