Multiple Error 1911.Could not register type library for file messages occur during System Recovery install

Article: 100024786
Last Published: 2018-05-24
Ratings: 0 1
Product(s): System Recovery

Problem

Attempting to perform a standalone / local install  Veritas System Recovery (VSR) generates the errors listed below, reports that the install completed  successfully but fails in either backup job creation or in its execution.

Error Message

Error 1911.Could not register type library for file <PATH_AND_FILE_TO_PRODUCT_DLLs>.  Contact your support personnel.

List of product DLL's affected:
C:\Program Files\Veritas\Veritas System Recovery\Shared\VProProgress.dll
C:\Program Files\Veritas\Veritas System Recovery\Agent\V2iToc.dll
C:\Program Files\Veritas\Veritas System Recovery\Agent\SpnRegister.dll
C:\Program Files\Veritas\Veritas System Recovery\Shared\ErrorGui.dll
C:\Program Files\Veritas\Veritas System Recovery\Console\RemoteCommand.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\VProObj.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\VProAuto.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\VProScheduler.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\NotifyHandler.dll
C:\Program Files\Veritas\Veritas System Recovery\Agent\VProImaging.dll
C:\Program Files\Veritas\Veritas System Recovery\Console\ObjectPicker.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\EventMonitors.dll
C:\Program Files\Veritas\Veritas System Recovery\Shared\EasySetupInt.dll
C:\Program Files\Veritas\Veritas System Recovery\Console\ExchMapi32\ExchMapi32.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\ComLicense.dll
C:\Program Files\Common Files\Veritas Shared\VProRecovery\ComConfig.dll

Error seen in Windows Application & System logs:

Application Error    Faulting application SymSnapServicex64.exe, version 1.0.22.35428, time stamp 0x4ab008aa, faulting module SymSnapServicex64.exe, version 1.0.22.35428, time stamp 0x4ab008aa, exception code 0xc0000417, fault offset 0x000000000013ce68, process id 0x224c, application start time 0x01cc1baaf6467e6e.

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Event ID:      10009
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Description:
DCOM was unable to communicate with the computer <SYSTEM> using any of the configured protocols.

Log Name:      Application
Source:        MsiInstaller
Event ID:      11911
Task Category: None
Level:         Error
Keywords:      Classic
Description:
Product: Veritas System Recovery 18 -- Error 1911.Could not register type library for file <PATH_AND_FILE_TO_PRODUCT_DLLs>.  Contact your support personnel.
 

Cause

Inadequate credentials specified in DCOM

Solution

1. Open a command prompt as an Administrator (i.e. Run as Administrator)

2. Change to the subfolder where fixinstall is located (i.e. Default path = \Program Files\Veritas\Veritas System Recovery)

3. Run fixinstall.bat

4. Reboot

5. Attempt to create/run a new backup job.

Was this content helpful?